PDA

View Full Version : CRP123 fault codes



danewilson77
09-30-2017, 08:49 AM
Can any of you coding buddies explain the below?

2004, 330i, ZHP, 146K miles, 17" rims, very little PM performed on this vehicle.

I have ideas on a few, but a few I have no idea.

Thank you https://uploads.tapatalk-cdn.com/20170930/4ca6808f83f3b64158b5cce113c7f12c.jpghttps://uploads.tapatalk-cdn.com/20170930/037600be75353c1994ac6ff18f3768f6.jpghttps://uploads.tapatalk-cdn.com/20170930/51bf9b25ab63c0d5cea6da2d72afc967.jpghttps://uploads.tapatalk-cdn.com/20170930/079b75db05d748c854f864dc1de5f242.jpghttps://uploads.tapatalk-cdn.com/20170930/03a3a6467464121397d3dc21056c3e58.jpghttps://uploads.tapatalk-cdn.com/20170930/60225ad179ed4dff63aa7dfbdb90f037.jpghttps://uploads.tapatalk-cdn.com/20170930/bb22d795523f52b28489390b4ecafeaf.jpg

Sent from my S8+

az3579
09-30-2017, 10:01 AM
Try clearing the codes and see what comes back.

Sent from my Pixel using Tapatalk

danewilson77
10-01-2017, 06:51 PM
Done. Thanks BP.

Sent from my S8+

ZHP_Brandon
10-01-2017, 08:28 PM
For starters, have you gotten your steering wheel air bag recall done? Or have you had to remove/replace any part of the wheel assembly?

The sensor is the round sensor sandwiched inbetween the steering wheel & the column it bolts up too.

My car had the same problem, and it would literally turn OFF while the key was in the ignition, car was running, and I was driving. Thankfully I didnít freak out but I almost crashed the first time it turned off, I just reacted quickly on the high way and swerved onto the shoulder like a bad fast and the furious scene

Tighten your battery terminals as well for peace of mind.

The sensor may require calibration after a recent service of some kind, its the easiest thing in the world to do
I recalibrated the steering angle sensor with a MaxiSys OBD2 scanner, and continued through the menuís until I stumbled upon the sensor and recalibrated it by leaving the steering wheel straight and having the car in accessory mode.

I hope this helps you Dane!


Sent from my iPhone using Tapatalk

danewilson77
10-02-2017, 12:54 PM
Thanks Sir. Much appreciated. We'll check it out.

Sent from my S8+