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How to set up a BMW Diagnostic Computer

After getting my computer set up, I've decided to start an ongoing DIY thread on how to set up a few programs for diagnostics and coding our E46. It'll be a brain
dump, if you will, while the information is still fresh on my mind. In attempt to reduce the amount of hotlinking to other forums or images, I'll try to cover
everything regarding installation within this thread. Please do not quote any of the images or steps, as this is an ongoing DIY.
As far as general use of the software, DO SO AT YOUR OWN RISK! This will cover:

Computer Requirements (Post 1)
VAG-COM OBD2 to USB cable modification and installation (Post 1)
INPA/EDIABAS installation (Post 2)
GT1/DIS installation (Post 3)
SSS/Progman installation (Post 4)

Computer Requirements
First, you'll need a computer with at least 2gb of RAM, ~40-80gb free HDD space, and Windows XP installed. Windows 7 (non-64bit) should work as well. I'm not
sure about Vista. With a Mac, installing Windows XP within Bootcamp will also work. For clarity's sake, this tutorial is based off what I'm currently running. 
My specs: Macbook Pro 2.4ghz Core2Duo, 15" LCD, 4gb RAM, 320GB hdd, with Windows XP SP3 running in Bootcamp (volume formatted as NTFS).
The great thing about my setup is that I'm sandboxed and only have a bare minimum Windows install. Should anything ever go wrong, I can wipe the partition
and start over. With a PC, you have a couple options: install it on your main XP setup, or reformat your hard drive and get two partitions with two separate
Windows installs... Or just buy an extra laptop.  The reason for this? You'll need to disable your antivirus and firewall for both the install and running of the
diagnostic software. Some folks don't like having protection turned off.

VAG-COM OBD2 to USB cable modification and installation
You'll need an USB/OBD2 cable; specifically a VAG-COM diagnostic cable. To minimize the amount of modifying that must be done to the cable, verify that it has a
FT232RL chip inside it. Verify with the seller, and verify when the cable arrives. It's printed on the chip surface (magnifying glass or loupe may be required).

I got mine from ECS Tuning on 3/21/2011. It was verified from other members that the cable has the FT232RL chip onboard.
You can also search eBay. Most are going to be from China, and will be much cheaper in price. You'll just have to wait 2-3 weeks to receive it. Here is one that
Tampa330i mentioned. Can't verify what chip is onboard though.
If you receive a cable that has a chip other than the FT232RL, like the FT232BL for instance, more modifications will be needed (soldering resistors), and that is
outside the scope of this DIY. So make sure you get the right one!
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When you receive the cable, some pins will need to be modified (soldered together) to bridge the K connections so it can talk to our E46. Pins 7 and 8 need to be
bridged. Open the OBD2 end of the cable by removing 2-4 screws. Heat up the soldering gun and dab a little solder to connect the two pins, as seen in the
photos. The pinout diagram will shows the proper OBD2 connector orientation.

 

Here are the drivers needed to get XP to talk to the cable. CDM 4.2.1916 WHQL certified
Extract them to the desktop. Plug the cable into the USB port. Found New Hardware Wizard should pop up. Click Not at this time. Click Next.

Click Install from a list or specific location, and Next.

http://tech.yostengineering.com/servoFolder/servocenterUSB/cdm-2-04-16-whql-certified.zip/at_download/file
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Uncheck Search removable media. Check Include this location in the search. Click Browse and locate the folder of the extracted driver files. Click Next.

It will install, then click Finish.

The Found New Hardware Wizard will pop up again. Repeat the same process above.

Now we need to modify the driver settings. Go to Start -> Control Panel -> System
Click the Hardware tab



7/30/11 9:57 PMHow to set up a BMW Diagnostic Computer

Page 4 of 61http://www.zhpmafia.com/forums/showthread.php?1808-How-to-set-up-a-BMW-Diagnostic-Computer

Click Device Manager

Within Ports (COM & LPT), there should be an entry for USB Serial Port (COM#). Double click it.
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Click the Port Configuration tab and click Advanced 

Change the COM# to COM1, and change the Latency to 1ms. Click OK in every box to get back to the desktop.
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Now we need to modify the EEPROM on the FT232RL chip to communicate properly with our car.
Download MProg 3.5 and extract it to the desktop. Open it and go to Tools -> Read and Parse. The cable should pop up.

Next, check Invert DSR#, check Invert RI#. Click the Save icon and save it somewhere. Click the Flash icon (lightning bolt) and you should see a successful
programming in the bottom field.

http://www.ftdichip.com/Resources/Utilities/MProg3.5.zip
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Info taken from http://forums.bimmerforums.com/forum....php?t=1505990

Last edited by spencers; 03-23-2011 at 10:23 AM.
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EDIABAS/INPA
This is the main software that is used to get initial connectivity with the VAGCOM cable. Again, I will not delve into what you can do with the software itself, but
simply how to get it installed and operating so DO SO AT YOUR OWN RISK!.
You cannot go any further with DIS or SSS without EDIABAS correctly configured, working, and talking with your E46.

You'll need:

ediabas-6.4.3-full.nrg Password: zhpmafia
Daemon Tools Lite
Working VAGCOM cable from (Post 1)

For the entirety of this tutorial, you should have your antivirus and firewall disabled.

First and foremost, go to Start -> Control Panel -> System. Click the Advanced tab.
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Then click the Environment Variables button

Find the Path system variable, click it, and click the Edit button

At the end of the Variable value, add a semicolon, and add "C:\EDIABAS\Bin"
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Press all the OK buttons until you're back to the desktop.

Now to begin the install. I assume you have already installed Daemon Tools Lite.
Drag the ediabas-6.4.3-full.nrg file to Daemon Tools, then right click it within Daemon Tools and mount the image. 

Navigate to "<CD DRIVE>:\Referenz\INSTALL" and launch the file "Instprog.exe"

Click ok to any dialog boxes that come up

Select English. Press Continue.
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Press Continue.

Leave C:\ as the destination drive and press Continue.

Select BMW Group Rectification programs USA and press Continue.
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Place check marks on the Complete options for EDIABAS and INPA. Press Continue.

Select OBD as the interface and press Continue.

Press End when the installation has completed. The program may freeze for a few seconds, so don't be alarmed.
If you get any errors before clicking End, it's because you didn't properly add the Environment Variable as listed above.
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Now let's set up EDIABAS to talk to the cable. 
Navigate to "C:\EDIABAS\Bin" and open EDIABAS.ini with Notepad.

Locate the line for "RemoteHost" and "Port" and adjust the value to "192.168.68.1" and "6801"
Then save and close the file.

Navigate to "C:\EDIABAS\Hardware\OBD" and launch launch the file "OBDSetup.exe"
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A screen similar to this should appear. Press any key to close it. At this point, it is best to restart the computer.

Be sure your firewall and antivirus are disabled when your computer comes back up.
Verify that your cable is still set to COM1 within the Device Manager (Post 1)

Go out to the E46. Plug the cable into the OBD2 port and turn the key to position 2 (position right before the car starts).
Start INPA using the shortcut in the start menu called "INPA(_.IPO)"
The Battery and Ignition dots should be black

Press F3 for E46, click Engine, and find your DME. 
ZHP is MS45 (if I recall)
ZSP is MS43.
If successful, you should get an info screen up with infos about your car.

http://www.zhpmafia.com/forums/showthread.php?1808-How-to-set-up-a-BMW-Diagnostic-Computer&p=36771#post36771
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Further tinkering around with the software is done AT YOUR OWN RISK.

Info taken from: http://forums.bimmerforums.com/forum....php?t=1312104
As well as a PDF by unknown author called How to Install INPA 5.02 and Ediabas 6.4.7.pdf

Last edited by spencers; 03-23-2011 at 12:39 PM.
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DIS/GT1
Ready for a tougher install? I assume you already have your computer set up with the OBD2 cable and fully working with the EDIABAS protocol and INPA
communicating with your car. This is imperative before continuing! What you'll need:

EasyDIS-base-44-v1.0.nrg Password: zhpmafia
GT1_v44_programs.iso Password: zhpmafia
VMWare Workstation Password: zhpmafia
Daemon Tools Lite
Working VAGCOM cable from (Post 1)
Working EDIABAS/INPA install from (Post 2)

Install VMWare Workstation as normal. Open VMWare and create a new virtual machine.
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Select Typical

Select Other - Other

Name the VM "GT1"
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Select Host Only networking

Enter 18.635 as the hard drive size, and select allocate disk space now

Click Finish and the VM is created.
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Edit the VM Hardware and remove the Sound Adapter

Adjust the Network Adapter to use VMNet1 (host only)

Switch to the VM Options tab and uncheck drag-and-drop from Guest Isolation
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Mount "EasyDIS-base-44-v1.0.nrg" in Daemon Tools Lite

Edit the CD Drive of the VM to use the Daemon Tools drive (F: in this case)

Start the VM. It will reboot once after installing the kernel, then GT1 will install.
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After the installation is finished, it will ask you to eject the CD and restart.. But DONT RESTART YET!

Unmount "EasyDIS-base-44-v1.0.nrg" in Daemon Tools Lite, and Mount "GT1_v44_programs.iso"
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Now right click the VM in the list and choose Power Off. Then choose Power On. GT1 will finally come to life!

Select English as the language

Select USA as the country, and enter 12345 as the Dealer Number. Fill in the rest with whatever you'd like.
After entering in everything, click the End button and select Quit.
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DIS comes up!

Click the Admininstration button. Verify that the DIS v44 Programs CD is loaded. Then under DIS, click Installation.

Enter the Dealer Number as the password. 12345

Wait a while....
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Installation will complete!

Now we need to safely power off DIS. Click the Calibrating touch Shield button

Type in the Dealer Number as the password: 12345

Now Press 0 to Shutdown DIS. You may also now unmount the DIS v44 Programs cd from Daemon Tools Lite.
You should ALWAYS shut down DIS via this method.
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Now we need to make some changes in order to get the cable to communicate with DIS.
Open the Manage Virtual Networks tool and click the Host Virtual Network Mapping tab.

Under VMNet1, click the arrow and click Subnet...

Enter 192.168.68.0 as the IP Address and press OK.

Navigate to "C:\EDIABAS\Bin" and launch IFHSrv32.exe
*Make sure your firewall/antivirus is disabled!*
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It will launch in the background and appear on the task bar. No window will come up.

Power on the GT1/DIS VM. Click the Administration button.

Click the Calibrating touch Shield button

Type in the Dealer Number as the password: 12345
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Press 7 SCOAdmin Network

Apologies, currently no screen shots available yet
A window will pop up showing 2 green driver icons. At the top of the screen will be the SCO TCP/IP Loopback driver. DO NOT TOUCH THIS DRIVER!

Below that, you'll see a second driver, the AMD PCNet-PC1 Adapter Compatible -PC1 Bus#0, Device#17, Function#0. Click it and from Hardware menu, click
Remove network device.

Now, go to the Hardware menu and click Add new LAN adapter. A window will pop up showing AMD PCNet-PC1 Adapter Compatible devices found on your
computer. Click it and then Yes to add the new adapter.

Choose SCO TCP/IP as the protocol. 
Change Local Host Name to: gt1ap
Change IP Address to 192.168.68.30
Everything else should automatically populate: Netmask: 255.255.255.0 Broadcast Address 192.168.68.255 TCP connections and Pseudo ttys lines. Click OK to
accept.

Go to the Hardware menu and click Exit. A window will pop up for you to relink the kernel due to the changes you made. Choose Yes.

A black window will pop up asking you again to relink the kernel. Choose Yes to all prompts. The VM will reboot. Follow the instructions above to get back to this
window. Press 7 SCOAdmin Network

Click somewhere in the screen and press CTRL+Print Screen(SysRq) to access the UNIX command line.

At the login prompt type root
Choose option 1 to choose a password. For the easiest to remember, I recommend: password
A few lines of text will be generated, the last being TERM = (scoansi) _
Hit the enter key.
Type: cd /etc
Press enter
Type: vi hosts
Use the arrow key to move the cursor down to the entry 127.0.0.1 localhost
Press the "o" key to add an empty line below it.
Now, without any typing mistakes, add 192.168.68.1 diaghead diaghead
Keystrokes should be: 192.168.68.1(TAB)diaghead(SPACE)diaghead
Press ESC
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Type: :wq
Now type: init 0

DIS should shut down.

Power on the GT1/DIS VM. Click the Administration button.

Click the Calibrating touch Shield button.

Type in the Dealer Number as the password: 12345

Press 1 to Configure EDIABAS.
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Press 2 to run API test. You should see this screen if successful

If not, you have a network communication problem.

Exit the screen by pressing 0. When back to the main screen, press 9 to Exit.

DIS Will come back up. Connect the OBD2 cable to your car. Click the Diagnosis button.
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Select your Series and Model series. Click the green arrow.

You might run into errors about battery power. Click OK.

You might have to manually select your car. If so, click Manual.

Choose your car and click the green arrow.
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Now you can play around!

Further tinkering around with the software is done AT YOUR OWN RISK.

Info taken from: http://forums.bimmerforums.com/forum....php?t=1401774
http://forums.bimmerforums.com/forum...67&postcount=4
"Using CarSoft Interface with INPA" PDF, by MaikelK

Last edited by spencers; 06-27-2011 at 11:25 AM.
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03-22-2011 12:58 PM

Join Date:
Location:
My Ride:
Posts:

Dec 1969
Texas

2001 325Ci ZSP
706

SSS/Progman
Installing this program is very intuitive, and requires the use of the Registry Editor. Again, I assume you already have your computer set up with the OBD2 cable
and fully working with the EDIABAS protocol and INPA communicating with your car. This is imperative before continuing! What you'll need:

SSS Base 3.1 hack.iso Password: zhpmafia
BMW.SSS.Progman.v28.0.0.9.iso Password: zhpmafia
Changes.iso Password: zhpmafia
VMWare Workstation Password: zhpmafia
Daemon Tools Lite
Working VAGCOM cable from (Post 1)
Working EDIABAS/INPA install from (Post 2)

If you don't already have VMWare Workstation installed, install it as normal. Open VMWare and create a new virtual machine. Select Typical.

#4

Enforcer
spencers 
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http://www.4shared.com/dir/hEWYtgWJ/sharing.html
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http://www.4shared.com/dir/hEWYtgWJ/sharing.html
http://www.4shared.com/dir/hEWYtgWJ/sharing.html
http://www.daemon-tools.cc/eng/products/dtLite
http://www.zhpmafia.com/forums/showthread.php?1808-How-to-set-up-a-BMW-Diagnostic-Computer&p=36771#post36771
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Select the operating system: Microsoft Windows, and select the version: Windows XP.

Give the virtual machine a name. SSS Progman is fine. Next, select Use host-only networking.

Set your disk size to 80 GB. You don't need to allocate all disk space now.
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The VM is created!

Now, edit the VM and remove the USB controller and the Sound Adapter. 
Increase the Memory to 1gb. 
Adjust the Network Adapter to use VMnet1 (Host-only)

Edit the CD drive to Use ISO image: SSS Base 3.1 hack.iso
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Power on the VM and the install will start.

When it completes, it will ask you to eject the CD.
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Double click the CD icon in the lower-right corner of the VMWare window. Change Connection to Use physical drive.

Power off the VM, then power it back on. The installation will begin.
If the installer asks you for the Progman installation disk, press cancel!
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When complete, power off the VM. Double click the VM's Hard Disk (under devices in the main VMWare window).
Select Utilities -> Map.
Select the first partition, uncheck Open file in read-only mode, and press OK.

Open regedit. Start -> Run -> type in regedit and press OK.

In the Registry Editor, click File -> Load Hive.
Browse or copy-paste the location Z:\Windows\System32\Config\Software
Give the hive the name of BASE31
It will then show up in the registry.
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Drill down to BASE31\Microsoft\Windows NT\Current Version\Winlogon
Find the value named Shell and double click it.

Change the value to Explorer.exe

Collapse the folder so that BASE31 is highlighted
Go to File -> Unload Hive
Then close the Registry Editor.

Go back to VMWare and open the properties for the Hard Disk again and select Utilities -> Disconnect
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Start the Progman VM and it should boot into Windows XP. Click cancel to any messages about installing new hardware.
Now log-off the machine. Start -> Log Off
Log back in with the username: Administrator
and the password: ++Xs4Progman

Open the control panel. Start -> Control Panel

Open Administrative Tools
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Open Component Services

Choose Services (Local) and find Progman AOS Service. Double click it.
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Click the Stop button to stop the service.

Close out, go back to the Control Panel and open System.
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Click the Hardware tab and open Device Manager

At this point, we need to install VMWare Tools. Go to the VM menu at the top of the VMWare window and Install VMWare Tools. After installing, it may ask you to
restart. If it does restart, be sure to follow the directions again to log-out and log back in as Administrator with the password ++Xs4Progman
Again, click cancel to any messages about installing new hardware.
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Open the Control Panel. Start -> Control Panel
Open Display.

Set the resolution to 1024x768 and click OK.
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Open User Accounts
Click on WorkUser
Select Change Account Type
Make the account a Computer Administrator

Double click the CD icon in the lower-right corner of the VMWare window. Change Connection to Use ISO, and select SSS Base 3.1 hack.iso
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Open My Computer. Start -> My Computer
Locate the Progman 3.1 CD, and find HWver.dll

Highlight it, right click and Edit -> Copy to Folder
Type or copy-paste C:\Windows\System32
Select Yes to overwrite.
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Go back to the Progman AOS Service. Start -> Control Panel -> Administrative Options -> Component Services -> Services (Local) -> Progman AOS Service
Click the Start button, and click OK.

Open regedit within the VM. Type Windows Key + R to bring up the run menu, and type regedit
Drill down to HKEY_LOCAL_MACHINE\Software\Microsoft\Windows NT\Current Version\Winlogon
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Find the value named Shell and double click it.
Adjust the Value to C:\WINDOWS\system32\ifs\install\instprg.exe -prg

Shut down the VM. Start -> Shut Down
Edit the CD drive to Use ISO image: BMW.SSS.Progman.v28.0.0.9.iso
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Power on the VM and the installation will begin. Click Cancel to any message(s) about agp440.sys

When finished, you'll finally land at a setup screen! Select English and press Continue.

Enter the information seen below into the fields
SSS name: PROGMAN
IP address: 192.168.68.50
Gateway: 192.168.68.1
IP subnet mask: 255.255.255.0
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Leave the printer info blank and press Continue.

Click Continue again.
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Select USA. For the Dealer Number, enter 12345
Make up the rest of the info, and click Finish.

Windows will shut down and attempt to reboot. As soon as it shuts down, POWER OFF the VM to prevent it from restarting.
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We must now make some more changes with the Registry Editor. Double click the VM's Hard Disk (under devices in the main VMWare window).
Select Utilities -> Map.
Select the first partition, uncheck Open file in read-only mode, and press OK.

Open regedit. Start -> Run -> type in regedit and press OK.

In the Registry Editor, click File -> Load Hive.
Browse or copy-paste the location Z:\Windows\System32\Config\Software
Give the hive the name of BASE31
It will then show up in the registry.
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Drill down to BASE31\Microsoft\Windows NT\Current Version\Winlogon
Find the value named Shell and double click it.

[

Change the value to Explorer.exe

Collapse the folder so that BASE31 is highlighted
Go to File -> Unload Hive
Then close the Registry Editor.

Go back to VMWare and open the properties for the Hard Disk again and select Utilities -> Disconnect
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Edit the CD drive to Use ISO image: changes.iso

Power on the VM and it will boot to Windows XP. Again, click cancel to any messages about agp440.sys

Open My Computer. Start -> My Computer
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Double click the CD Drive Changes (drive letter)
A command window should open. If the window does not open and you just see the contents of the CD drive, double click sss_stage2
Press any key to continue.

The command window will make some changes and ask you to press any key to continue again.
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Now restart the VM. Start -> Shutdown -> Restart
While the VM is restarting, open IFHSrv32.exe on your computer from C:\EDIABAS\Bin
Make sure your firewall/antivirus is disabled!
Progman will finally come up!
Now lets set up the cable to communicate with Progman. Click on the Administration button.

Click the Interfaces button on the left.
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Click the External interface button on the left.

Click the Add button on the left.
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Enter 192.168.68.1 as the IP address and click Continue.
Then you'll be back at the Interface screen. Click the Home button.

Now let's get the cable to communicate. Connect the cable to your car as you normally would and verify that INPA can talk to the car.
Now back in Progman, click New Session and you should see the interface. Select it and press Continue.
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Enter any name as the description

Select your car. 3 Series
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Select the model series. E46

Then the vehicle order will be determined. It takes a few minutes. 
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Finally, you should land at this screen. If you do, it works! Have fun playing around. 

Further tinkering around with the software is done AT YOUR OWN RISK.

Info taken from: http://forums.bimmerforums.com/forum....php?t=1401774

Last edited by spencers; 03-23-2011 at 12:37 PM.
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Join Date:
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Williamsburg, VA

2/2004 330i
10,612

Spencer. Thanks for the wealth of information. Excellant writeup. I may even take this one someday.
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Become a ZHPMafia.com Subscriber Today -- Click Me
BMW CCA # 432214

Jim Conforti Shark Injected ZHP l AFE Pro 5 R CAI l Yokohama AVID ENVigor 235/40/18's l Enkei EKM3's l KW V1 Coilovers l Cusco Strut Bar l Custom Trim l Weisslicht AE's l No Hole License Plate Bracket l
Colgan Nose Mask l Thule Rack l NBS Euro Side Mirrors
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Join Date:
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My Ride:
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Feb 2011
San Antonio, TX
10/03 330i ZHP

360

OMG thank you for starting this!

I fully plan to do this as soon as I get a cable; I was dreading the amount of searching & forum reading I was going to have to do to get it all working.

'04 ///ZHP sedan 6MT
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Crickett 
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10,806

Great work, Spencer. Tremendous.

Join the ZHP Mafia Special Interest Group Today
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ZHPMafia.com Founder
Marcus-SanDiego 

         Reply Reply With Quote   

03-22-2011 10:21 PM #8

http://www.zhpmafia.com/forums/showthread.php?1472-ZHPMafia.com-Subscription-Service
http://www.zhpmafia.com/forums/newreply.php?do=newreply&p=36778
http://www.zhpmafia.com/forums/newreply.php?do=newreply&p=36778
http://www.zhpmafia.com/forums/newreply.php?do=newreply&p=36778
http://www.zhpmafia.com/forums/report.php?p=36778
http://www.zhpmafia.com/forums/showthread.php?1808-How-to-set-up-a-BMW-Diagnostic-Computer&p=36811#post36811
http://www.zhpmafia.com/forums/member.php?587-Crickett
http://www.zhpmafia.com/forums/member.php?587-Crickett
http://www.zhpmafia.com/forums/newreply.php?do=newreply&p=36811
http://www.zhpmafia.com/forums/newreply.php?do=newreply&p=36811
http://www.zhpmafia.com/forums/newreply.php?do=newreply&p=36811
http://www.zhpmafia.com/forums/report.php?p=36811
http://www.zhpmafia.com/forums/showthread.php?3621-Join-ZHP-Mafia-Special-Interest-Group
http://www.zhpmafia.com/forums/showthread.php?1808-How-to-set-up-a-BMW-Diagnostic-Computer&p=36837#post36837
http://www.zhpmafia.com/forums/member.php?2-Marcus-SanDiego
http://www.zhpmafia.com/forums/member.php?2-Marcus-SanDiego
http://www.zhpmafia.com/forums/newreply.php?do=newreply&p=36837
http://www.zhpmafia.com/forums/newreply.php?do=newreply&p=36837
http://www.zhpmafia.com/forums/newreply.php?do=newreply&p=36837
http://www.zhpmafia.com/forums/report.php?p=36837
http://www.zhpmafia.com/forums/showthread.php?1808-How-to-set-up-a-BMW-Diagnostic-Computer&p=37218#post37218


7/30/11 9:57 PMHow to set up a BMW Diagnostic Computer

Page 59 of 61http://www.zhpmafia.com/forums/showthread.php?1808-How-to-set-up-a-BMW-Diagnostic-Computer

Quick Reply

Join Date:
Location:
My Ride:
Posts:

Jan 2011
Massachusetts

2005 330Ci ZHP
338

Thank you Spencer, I fiddled around with it a couple weeks ago but failed to get it completely working - hopefully by following these instructions I can get it to
work right!

My Project Thread
Register Your ZHP | CoolantSnitch

2005 ZHP 6MT Mods: AFE Intake, Carbon Fiber Hood w/ M3 Bulge, Meyle HD FCAB's, Zionsville T-Stat @ 88°C, Stewart WP, BMW Perf. Rotors F+R, Oil Temp &
Press. Gauges, Alcantara Wheel w/ CF Trim, Alum. Pedals + E-Brake, Black Kidney's, Aux Input, Beltronics RX-75 Pro Radar Detector, Beisan Seals + Rattle Kit,
Armrest Delete, Schroth Harness, StopTech Pads, SSR Comp-H's

Enforcer
MasterC17 
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Dec 1969
Bridgeport, CT

2,975

Wow. This is exactly what I was going to do and didn't have enough time to complete. 
Thanks for saving me allllll that time writing it up and trying to get it to work... will give it a go when I come back from vaca!

Botond Pal
2005 330i ZHP / 6MT
Connecticut Valley Chapter
Patroon Chapter
Imolarot / Alcantara

Remember, it's not the car you drive, it's how you drive it.
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Wow, Spencer! Once I have taxes finished and archived, I'm definitely going to try this on my Windows partition! Exciting!
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