Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: my ZHP takes much longer to warm up than my my dad's 330

  1. #1
    Join Date
    Nov 2013
    Location
    Bay Area
    Posts
    2,972

    my ZHP takes much longer to warm up than my my dad's 330

    So I've had my ZHP for 2 months now. I've noticed that it takes much longer to warm up to full operating temp than my 325 as well as my dad's normal 330.

    For example, I have a ~15 mile freeway commute from class (at night). By the time I get home the temperature is just barely on the little icon in the middle of the temperature gauge, but I can tell it's not fully centered, and therefore, not fully warmed up.

    Any thoughts on this?


    His: 05 330 ZHP Imola Red - 07 Z4 M Coupe Imola Red
    Hers: 04 330i ZSP
    2004 325 M56 Steel Blue Metallic - Sold
    Stephen's DD & AutoX/HPDE Build Thread
    Stewart WP - Z4M LCAB - M3 trans/motor mounts - DICE MediageBridge Duo - ARC-8 17x8.5"
    DrVANOS - Mason Engineering Race Strut Bar - E30 Exp. Cap - Custom Black+Beige Interior - M3 Seats
    Bilstein PSS10 - Turner Sway Bars 27/21 - ECST RTAB Limiters - R.E. RSM


  2. #2
    Join Date
    Dec 2012
    Location
    Sacramento, CA
    Posts
    6,866
    New thermostat, unless it's been replaced recently. OEM only!
    2003 Oxford Green ZSP 5MT 330i
    "I thought you were the car whisperer, Dario." -johnrando

  3. #3
    Join Date
    Apr 2011
    Location
    Bay Area, Cali
    Posts
    1,529
    ^Yep.

    Although anywhere between the two lines is considered "warm"

    My 323 has a sticky t-stat because it will warm up then cool down to the blue all on its own again. I'm sure this doesn't help my mpg :/

  4. #4
    Join Date
    Jan 1970
    Location
    Lebanon, OH
    Posts
    37,872
    Quote Originally Posted by Avetiso View Post
    New thermostat, unless it's been replaced recently. OEM only!
    Quote Originally Posted by Johal E32 View Post
    ^Yep.

    Although anywhere between the two lines is considered "warm"

    My 323 has a sticky t-stat because it will warm up then cool down to the blue all on its own again. I'm sure this doesn't help my mpg :/
    This.

    Sent from my S4 > Mason, OH
    "Flame suit NOT REQUIRED!!!"
    Call Me Dane l 2/2004 330i ZHP l 18x8 ET45 BBS CK's wrapped with Michelin Pilot Sport AS3+ @ 245-40-18 l KW V1 Coilovers in front l KW V1 springs w/ Bilstein B8 dampeners in rear l BMW Performance Rotors l UUC StrutBarbarian l Racing Dynamics Rear Strut Bar l Jim Conforti Shark Injector l Light Birch Interior Trim l Bimmian Celly Mount l M3 Trunk Mat l l e90 Performance E-Brake & Shift Knob l M3 Tri-Stitched Boots l AL Headlight Retrofit with ZKW Lenses l CobyWheel Wrap w/M3 Stitching l LCM sw 4.5 triple blink and rear fogs

  5. #5
    Join Date
    Sep 2011
    Location
    North Jersey
    Posts
    686
    I've noticed this winter my temp gauge will stay between the blue and 50% a lot longer than last winter. I really doubted that all of a sudden it doesn't warm up quickly. Your problem as well as mine is probably a thermostat.
    2006 MINI Cooper S SOLD
    http://www.zhpmafia.com/forums/showt...-MINI-Cooper-S
    2006 ZHP 330CiC



  6. #6
    Join Date
    Nov 2013
    Location
    Bay Area
    Posts
    2,972
    Interesting. I'll have to look. The hoses going to the thermostat and the like all look quite new... doesn't mean the thermostat got changed, though!

    With the holidays coming up and the finals for my last MBA semester, time to do car work is pretty limited. Is this something I can drive around on without worrying for a bit?


    His: 05 330 ZHP Imola Red - 07 Z4 M Coupe Imola Red
    Hers: 04 330i ZSP
    2004 325 M56 Steel Blue Metallic - Sold
    Stephen's DD & AutoX/HPDE Build Thread
    Stewart WP - Z4M LCAB - M3 trans/motor mounts - DICE MediageBridge Duo - ARC-8 17x8.5"
    DrVANOS - Mason Engineering Race Strut Bar - E30 Exp. Cap - Custom Black+Beige Interior - M3 Seats
    Bilstein PSS10 - Turner Sway Bars 27/21 - ECST RTAB Limiters - R.E. RSM


  7. #7
    Join Date
    Nov 2013
    Location
    Bay Area
    Posts
    2,972
    *edit*
    double post.

    I'm getting a lot of "database errors" when posting


    His: 05 330 ZHP Imola Red - 07 Z4 M Coupe Imola Red
    Hers: 04 330i ZSP
    2004 325 M56 Steel Blue Metallic - Sold
    Stephen's DD & AutoX/HPDE Build Thread
    Stewart WP - Z4M LCAB - M3 trans/motor mounts - DICE MediageBridge Duo - ARC-8 17x8.5"
    DrVANOS - Mason Engineering Race Strut Bar - E30 Exp. Cap - Custom Black+Beige Interior - M3 Seats
    Bilstein PSS10 - Turner Sway Bars 27/21 - ECST RTAB Limiters - R.E. RSM


  8. #8
    Join Date
    Dec 2012
    Location
    Sacramento, CA
    Posts
    6,866
    Quote Originally Posted by stephenkirsh View Post
    *edit*
    double post.

    I'm getting a lot of "database errors" when posting
    Same. Database errors and double posts everywhere.
    2003 Oxford Green ZSP 5MT 330i
    "I thought you were the car whisperer, Dario." -johnrando

  9. #9
    Join Date
    Oct 2011
    Location
    Silicon Valley
    Posts
    1,630
    Should be okay for a while. Besides hurting your gas mileage, it might prevent your oil from burning off extra moisture as well, but if you've got a 15-mile drive the oil is probably getting hot enough.

    If you're replacing your thermostat and the expansion tank is original, replace that too! It may be possible to see the label on the side of the ET with a mirror to figure out if it's original or when it was replaced.
    Quote Originally Posted by stephenkirsh View Post
    Interesting. I'll have to look. The hoses going to the thermostat and the like all look quite new... doesn't mean the thermostat got changed, though!

    With the holidays coming up and the finals for my last MBA semester, time to do car work is pretty limited. Is this something I can drive around on without worrying for a bit?

  10. #10
    Join Date
    Nov 2013
    Location
    Bay Area
    Posts
    2,972
    How does it impact fuel mileage?


    His: 05 330 ZHP Imola Red - 07 Z4 M Coupe Imola Red
    Hers: 04 330i ZSP
    2004 325 M56 Steel Blue Metallic - Sold
    Stephen's DD & AutoX/HPDE Build Thread
    Stewart WP - Z4M LCAB - M3 trans/motor mounts - DICE MediageBridge Duo - ARC-8 17x8.5"
    DrVANOS - Mason Engineering Race Strut Bar - E30 Exp. Cap - Custom Black+Beige Interior - M3 Seats
    Bilstein PSS10 - Turner Sway Bars 27/21 - ECST RTAB Limiters - R.E. RSM


Page 1 of 2 12 LastLast

Similar Threads

  1. ZHP warm-up time
    By Stewbie in forum Mechanical | Troubleshooting
    Replies: 14
    Last Post: 10-03-2013, 08:28 AM
  2. Issues from cold start until warm
    By Alex in forum Mechanical | Troubleshooting
    Replies: 36
    Last Post: 01-23-2012, 02:55 PM
  3. Things That Give You a Warm Feeling on a Cold Night
    By kayger12 in forum Performance
    Replies: 60
    Last Post: 02-17-2011, 04:17 PM
  4. Help - Jumpy Idle and Stall in Warm / Hot Weather
    By Jet Moto in forum Mechanical | Troubleshooting
    Replies: 8
    Last Post: 02-14-2011, 05:09 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •