Page 3 of 56 FirstFirst 123451353 ... LastLast
Results 21 to 30 of 551

Thread: GotZHP's E46 330i ZHP Maintenance & Build Thread w/ Pics & DIYS

  1. #21
    I just replaced the lower intake boot today. I ordered one before I took the old one off because I figured it would have been torn and it was worn, but not broken.

    I have a bunch of photos from today I'll post up soon here

  2. #22
    Join Date
    Nov 2014
    Location
    Portland, OR
    Posts
    9,112
    Quote Originally Posted by GotZHP View Post
    So for cooling, this is the kit I am planning on getting. Going to get a new radiator as well. Just unsure of the new water pump. Need to research OEM vs metal impeller models.

    http://www.turnermotorsport.com/p-19...328i-330i.aspx
    That's the same kit I used last spring. No issues, everything works. I bought a standard BMW water pump instead of the Stewart pump. Supposedly the composite material in the impeller was improved by BMW since our cars came from the factory.

    Quote Originally Posted by GotZHP View Post
    So does this engine sound ok? I know there is a vacuum leak.... but anything else?

    http://s1268.photobucket.com/user/Go...stsuu.mp4.html

    http://s1268.photobucket.com/user/Go...g2rjj.mp4.html
    I can't really help you as these issues aren't ones I've ever encountered in person. Hope you figure out your issues, and be sure to let us know what they are and how you fixed them. Oddly, my engine very occasionally sounds like the second video. It's only got 52k miles on the motor so who knows.

  3. #23
    Join Date
    Nov 2012
    Location
    22841
    Posts
    9,236
    With the car running, press the clutch in and see if it the noise goes away somewhat.

    Also vacuum leak and vanos.

    His - 2004 Imola Red / Alcantara 330i | 6MT | ZHP |

    Her's - 2005 Black Sapphire Metallic / Black Leather 330i | 6MT | ZHP |

  4. #24
    Quote Originally Posted by Vas View Post
    Sounds like you still have a pretty significant vacuum leak.

    You cleaned the icv and installed a new lower boot right? What about the upper boot and the f-connector?

    The rattling noise could be coming from the vanos. The noise can be heard from the front of the valve cover and sounds like marbles in a can.


    Also for the water pump, go with the OE bmw. I just pulled out a Geba pump with roughly 30k. While it's not a bad pump, it started to rust and felt loose. Impeller was metal as well
    Vanos seals are on the list. Should probably do them sooner rather than later. I've developed a small oil leak as well, so Im thinking Vanos, fix oil leak, oil change. Should be a good use of a weekend.

  5. #25
    Thanks for all the input on the Cooling kits everyone. Seems like Turner is a good way to go. Hopefully be purchasing the kit soon. Took a photo of my expansion tank and it is the original. 12 years and 105,000 miles. Thing is a time bomb.
    Attached Images Attached Images  

  6. #26
    Couple updates for today. I posted about this in the trouble shoot thread to hopefully reach a larger audience, but will bring it up here as well. My brake booster hose does not look oem to me. Also, it is collapsing and quiet flat in many areas. Take a look. It may be related to my vacuum leak. My F connected and attached hose are ok, but the upper hose on the F connector could certainly be replaced. I listened inside the car for any noise cause by the break booster down by the foot well. No noise.
    Attached Images Attached Images       

  7. #27
    SO some work from the past two days. Torn down the air intake side of the motor some. New DISA, New lower intake boot, and cleaned ICV. I will write a DIY for this process. Pretty easy to be honesty. Very few tools required and only one I would consider a specialty tool bit that is not available in smaller standard tool kits. Keep an eye out for that DIY, should be up this weekend.


    Pictures!
    In order of appearance : Old Lower Intake Boot, Cleaning ICV, Old Lower Intake Boot, Upper intake boot, Worn Vacuum line on F connector
    Attached Images Attached Images      

  8. #28
    Join Date
    Sep 2011
    Location
    San Francisco, CA
    Posts
    6,817
    good work sir!

  9. #29
    So Vas, I tried your theory today after going for a short driving to the BMW dealership to pick up some bolts.

    Started car, let it come up to temp, 10 minute highway jaunt, 10 minutes back, parked. With the car parked in neutral it started to idle hunt. If I pushed the clutch pedal all the way to floor, the idle hunt was not as bad, almost not noticeable.

    Do I need to adjust my grab point of the clutch? I did this on my Subaru BRZ and it took a few tries to get perfect.

    I have a video I'll put up on my photobucket soon

  10. #30
    Quote Originally Posted by derbo View Post
    good work sir!
    Thanks Derbo! Check back in 30 -45 minutes and I will have much more photos from putting everything back together yesterday.

    Takes a lot of time to go through photos, find the ones that are focused, download from phone, rename, re-size, and then finally upload.

Page 3 of 56 FirstFirst 123451353 ... LastLast

Similar Threads

  1. Replies: 769
    Last Post: 07-28-2017, 08:55 AM
  2. Jconlin's Maintenance/Mod Thread
    By Jconlin16 in forum Maintenance
    Replies: 172
    Last Post: 05-19-2017, 07:23 PM
  3. Zooey the ZHP Maintenance Thread
    By JanMatt in forum Projects
    Replies: 29
    Last Post: 03-08-2016, 07:07 PM
  4. al.330imola Build/Maintenance Thread
    By al.330imola in forum Projects
    Replies: 12
    Last Post: 06-05-2014, 03:26 PM
  5. DW77 BMW 330i ZHP Vanos & Strut Tower Thread - Pics
    By danewilson77 in forum Maintenance
    Replies: 142
    Last Post: 01-05-2012, 02:35 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •