Page 3 of 9 FirstFirst 12345 ... LastLast
Results 21 to 30 of 88

Thread: Eonon GA6150 review

  1. #21
    Join Date
    Jan 2015
    Location
    Vancouver, BC
    Posts
    100
    Quote Originally Posted by ZHPizza View Post
    I drove my other car with the Android headunit for a few days and realized how much I missed the ease of Waze/Spotify/phone calls, so....I went ahead and ordered that 2G 8 core model. We'll see how it is in a few weeks!
    This one piqued my curiosity. Have you received the unit?

  2. #22
    Join Date
    Nov 2016
    Location
    Charlotte, NC
    Posts
    2,197
    Quote Originally Posted by onaquest View Post
    This one piqued my curiosity. Have you received the unit?
    I actually installed it last night and it worked beautifully for about an hour before something bad happened with my amp/speakers. I now have no sound even with the OE business radio. I'm investigating the issue and have reached out to the seller. It don't look no good.

  3. #23
    Join Date
    Oct 2016
    Location
    Frankfurt, Germany
    Posts
    507
    Damn, that really sucks.

  4. #24
    Join Date
    Jan 2015
    Location
    Vancouver, BC
    Posts
    100
    oh man, hopefully its something simple to fix

  5. #25
    Join Date
    Nov 2016
    Location
    Charlotte, NC
    Posts
    2,197
    Quote Originally Posted by ZHPizza View Post
    I actually installed it last night and it worked beautifully for about an hour before something bad happened with my amp/speakers. I now have no sound even with the OE business radio. I'm investigating the issue and have reached out to the seller. It don't look no good.
    Quote Originally Posted by Sreten View Post
    Damn, that really sucks.
    Quote Originally Posted by onaquest View Post
    oh man, hopefully its something simple to fix
    Man I'm an idiot.

    See where I said that it worked great for an hour or so? That was in the garage, car off, blasting music and playing with the headunit.

    Car. Off.

    I had drained the battery to where it would still power the dash lights/headunit/etc, but didn't have enough juice for the amp that powers all of the speakers in the car.

    Jumped it this morning and everything works just fine again. Idiot.

  6. #26
    Join Date
    Feb 2014
    Location
    Picton, ON
    Posts
    6,019
    ha!! glad you sorted it out. must've been a humbling feeling.
    peter

    2009 BMW 335i M Sport 6MT

    2007 BMW X3 3.0si M Sport 6MT

  7. #27
    Join Date
    Nov 2016
    Location
    Charlotte, NC
    Posts
    2,197
    Quote Originally Posted by slater View Post
    ha!! glad you sorted it out. must've been a humbling feeling.
    Big time. I just sent the seller another message and was trying to figure out a way of 'eating crow' that would translate over to Chinese well.

    I'm just happy that it works...and also really happy that my gamble worked this morning...my jumper cables weren't at the house, so (instead of doing the rational thing and taking the Mazda to work) I carefully rolled the red car back out of the garage, key in position 2, shifter in reverse, and was able to pop it to running on the first try. The stakes were exciting because if it didn't work, I would have a dead car stuck in the parking lot with windows/sunroof open and rain on the way.

    I like to party.

  8. #28
    Join Date
    Feb 2014
    Location
    Picton, ON
    Posts
    6,019
    oh man. wish you could've got that on video.
    peter

    2009 BMW 335i M Sport 6MT

    2007 BMW X3 3.0si M Sport 6MT

  9. #29
    Join Date
    Oct 2016
    Location
    Frankfurt, Germany
    Posts
    507
    Fun story and glad it worked out!

  10. #30
    Join Date
    Jan 2015
    Location
    Vancouver, BC
    Posts
    100
    This all sounds like something that would happen to me lol. Glad it worked out. If it's not too much trouble, could you post some likes and dislikes about the unit?

Page 3 of 9 FirstFirst 12345 ... LastLast

Similar Threads

  1. Eonon GA5150 User Review
    By az3579 in forum Product and Storefront Reviews
    Replies: 63
    Last Post: 07-25-2016, 04:09 PM
  2. WTB: Dynavin n6/ Eonon
    By Ssparrow in forum ZHP-Related Parts & Accessories (no vehicle sales)
    Replies: 1
    Last Post: 12-15-2015, 05:35 AM
  3. Eonon GM5150
    By brewer90 in forum ZHP-Related Parts & Accessories (no vehicle sales)
    Replies: 9
    Last Post: 10-25-2015, 06:31 PM
  4. Any Eonon Reviews?
    By TitanZHP in forum Audio | In Car Entertainment (ICE)
    Replies: 20
    Last Post: 06-23-2015, 08:39 AM
  5. Eonon GM5150
    By WOLFN8TR in forum Audio | In Car Entertainment (ICE)
    Replies: 231
    Last Post: 01-31-2015, 12:54 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •