Page 2 of 4 FirstFirst 1234 LastLast
Results 11 to 20 of 33

Thread: Cylinder #6 Misfire, only at ~6krpm

  1. #11
    Join Date
    May 2012
    Location
    Northern Michigan
    Posts
    491
    Unfortunately my issue has not been resolved yet.

    I just tried replacing all coils with new, no change.

    As a workaround for now, I used ByteTuner to change c_mis_max_nr_off_iv to 0 in the DME tune. This value controls how many cylinders are shut down when a misfire is detected. Default value is 2. I changed it to 0. I don't have cats, so no need to shut down cylinders if there's a misfire. Now when it does occur I get a single brief flash of the SES light, but otherwise I can't tell anything is going wrong, the car drives so good.

    Updated list of things I've tried:
    • Replaced all 6 spark plugs with new
    • Replaced all 6 coils with new
    • Replaced cyl 6 fuel injector and inspected the electrical connector
    • Confirmed AFR of about 11:1 at the time of the misfire (suggesting the fuel system is keeping up fine since its not leaning out)
    • Removed the ESS manifold and pressure tested to ensure the intercooler wasn't leaking coolant into the cylinder, pressure tested good, held 11psi for over 4 hours. Resealed manifold to head, fresh gaskets, torqued to spec.
    • Compression tested: between 209 and 211 psi across all 6 cylinders (gauge is out of calibration, its probably 20-30 psi off)
    • Free-rev to 6k RPM, held there, no misfires. Also drove in 2nd gear and held RPMs at 6300 for a few seconds, no misfires. It only happens under sustained load such as in 3rd+ gear wide open throttle.
    • Installed M3 motor mounts to match M3 trans mounts
    • Flashed known good tune used on prior track days to the car, still misfires
    • Replaced headers and installed all new hardware and gaskets, confirmed no exhaust leaks


    I'm starting to doubt some of my tests at this point, such as the pressure test I did on the ESS manifold. I applied 11psi to the inside of the intercooler circuit, which is the opposite direction of the pressure applied when the car is under full throttle. I should have applied vacuum to that circuit to better replicate the real world.

    I guess the only other thing I could validate is the wiring harnesses. Ignition looks solid, and it routes in a place that wouldn't be effected by the clutch job, and its right on top, and everything looks super clean with no cracks in the sheathing etc. But the fueling wiring harness is harder to inspect due to it routing behind and below the huge ESS manifold.

    Deathtrap, its interesting you repaired your ECT wiring, I wonder if an intermittent bad reading there would show up in some logs.

    I'm going to run a fresh log on the car to validate fueling stays strong, which I believe it does, but can prove it now that the DME isn't shutting down cylinders when a misfire is detected. I'll log ECT too and see what that looks like.

    It seems like these are the remaining possibilities at this point, probably in order of likelihood:
    • Intercooler coolant leak
    • Fueling wiring harness fault
    • Cam sensor failing intermittently? (seems highly unlikely or the symptoms would be different?)
    • Harmonics issue with the ATI damper, Sachs performance clutch, and OEM-style LUK dual mass flywheel (also seems highly unlikely)


    I cant think of anything else that it could possibly be, anyone else have any thoughts on this?
    2003 BMW 330i ZHP
    ESS Twin Screw Stage 2 - Wavetrac - Headers - Borla - BMW Performance
    Turner Motorsports - Powerflex - Hawk Performance

    Build thread: http://www.zhpmafia.com/forums/showt...yan-s-2003-ZHP
    Wheelwell: 2003 BMW 3 Series
    Fuelly: 2003 BMW 330i

  2. #12
    Join Date
    Jan 2019
    Location
    Tampa, FL
    Posts
    196
    Man I was going to suggest all new coils.

    Assuming everything else is good, what about a little extra carbon build up in that cylinder that is causing a hot spot, throwing the DME into a fit?

    It sounds a lot like the 2800k rpm misfires I get only under load in 3rd+ gear. Revs fine in neutral, don't feel it in lower gears, and can't be explained other than a reflash that most people are doing, which supposedly loosens up the O2 tolerances. It seems BMW really squeezed what they could out of these cars mixture-wise.

    For example, before I get to the point of flashing, I'm figuring something must have aged to get it the car to the level of having issues within a very restricted range. I was reading on one of the forums about how the DME at higher revs for the most part just runs off a set map, since it can't respond as quick to changes (no proof of this). If that is the case, this would lead me to think something mileage/age related has to do with the changes, and carbon build up could be one of those. I know some of these BMW engines can really carbon up over time. I'm running Marvel Mystery oil in my gas at the moment to see if anything improves. I cleared the adaptations before driving on a 400 mile round trip excursion. It ran much better. Started to come back, so then I added the MM. I thought I was crazy, but I surely notice a difference. Definitely not as bad and winds up quickly. I've had great luck with this stuff on my carb'd 85 Mustang, but I'm going to drive a lot more before I make a final call.

    Have you done a leak down test in case there is a slight bit of loss out a valve or something? Could be slightly burned or a bit of carbon stuck in there causing a slight leak, which may or may not show up on a compression test.

    Just my diagnostic thoughts, since you've pretty well covered things...
    '04 330i ZHP sedan | Mystic blue | Alcantara | 6MT | 111k
    '98 740il | Schwartz 2 | Sandbeige | 5AT | 238k | lowered on Bilsteins w/ B&G springs
    '00 540i sport | Titanium silver | Black | 5AT | 120k
    '85 Mustang GT convertible | Medium charcoal metallic | Gray | 5MT | 215k | one owner, all original

  3. #13
    Join Date
    May 2012
    Location
    Northern Michigan
    Posts
    491
    You know, I guess a leak down test is probably the only diagnostic test I haven't done yet. I dont think I'm geared up for it, I'll do some googling to see what equipment I would need to get it done.
    2003 BMW 330i ZHP
    ESS Twin Screw Stage 2 - Wavetrac - Headers - Borla - BMW Performance
    Turner Motorsports - Powerflex - Hawk Performance

    Build thread: http://www.zhpmafia.com/forums/showt...yan-s-2003-ZHP
    Wheelwell: 2003 BMW 3 Series
    Fuelly: 2003 BMW 330i

  4. #14
    Join Date
    Jan 2019
    Location
    Tampa, FL
    Posts
    196
    I got a quality OTC leak down tester off Amazon for around $60. Proved to me that the cold engine miss in my family's 90 Cadillac wasn't a mechanical issue. Almost zero leak down on the cylinder with the miss.
    '04 330i ZHP sedan | Mystic blue | Alcantara | 6MT | 111k
    '98 740il | Schwartz 2 | Sandbeige | 5AT | 238k | lowered on Bilsteins w/ B&G springs
    '00 540i sport | Titanium silver | Black | 5AT | 120k
    '85 Mustang GT convertible | Medium charcoal metallic | Gray | 5MT | 215k | one owner, all original

  5. #15
    Guess what decided to show up...

    I guess I'm not done yet

    Sent from my Pixel 2 XL using Tapatalk
    -Corey

    2003 Blue ZHP Sedan @ 210k
    Dead due to damaged valve. We will save her soul for future use, but the body will go to car heaven...or another owner...who may or may not turn her into a race car...

  6. #16
    Join Date
    May 2012
    Location
    Northern Michigan
    Posts
    491
    Aw dang.

    I finally just used ByteTuner to update the DME so that it doesnt shut down cyl 6 when a misfire is detected. So now its just a flashing dash light when it happens. I can't tell anything is wrong other than the flashing dash light when it happens.

    If you want to do the same, the parameter name is c_mis_max_nr_off_iv and you change it from 2 (default) to 0. This parameter controls the maximum number of cylinders the DME will shut down when a misfire is detected. Its intended to protect the catalytic converters. I run headers, so I'm not concerned with that.

    I hate to have to resort to this, but I'm at my wits end, I really don't know what is causing this.

    I do still plan to do a leak down test to see what that shows.
    2003 BMW 330i ZHP
    ESS Twin Screw Stage 2 - Wavetrac - Headers - Borla - BMW Performance
    Turner Motorsports - Powerflex - Hawk Performance

    Build thread: http://www.zhpmafia.com/forums/showt...yan-s-2003-ZHP
    Wheelwell: 2003 BMW 3 Series
    Fuelly: 2003 BMW 330i

  7. #17
    Bump.

    My misfire trigger RPM has decreased from ~6k, to around 4.5k.

    Notes:
    + I have a seriously negative fuel trim at around idle and constant throttle

    + O2s and cats are still old

    + Rattling noise at lower rpm during rough running (i.e. when injector cuts out)

    +Doesn't misfire when MAF is unplugged, MAF is new Siemens/VDO part.

    I'll redo the standard diagnostics this weekend, maybe I can detect something this time.

    Sent from my Pixel 2 XL using Tapatalk
    Last edited by DeathTrap; 10-03-2019 at 07:02 PM.
    -Corey

    2003 Blue ZHP Sedan @ 210k
    Dead due to damaged valve. We will save her soul for future use, but the body will go to car heaven...or another owner...who may or may not turn her into a race car...

  8. #18
    Fixed my fuel trims and MAF readings by tightening up the MAF pins, still didn't fix the misfire but I'll tighten up my other pins (coil, injector, DME) and see what happens. Compression is good, fuel pressure is good but couldn't check under a load...even if it was bad it would be a more global issue than cylinders specific.

    Another thing is the misfire detection method that BMW has implemented is not 100%. Looking at the firing order for the straight 6, cylinder 3 fires before 6. Let's say, hypothetically, that cylinder 3 is the one misfiring. Then the misfire may get detected on the next "cycle."

    Also, I am wayyyyyyy down on power. The car feels like a dog, I have to really push it just to keep up with even a 4 cyl Altima...this isn't fun.

    Sent from my Pixel 2 XL using Tapatalk
    -Corey

    2003 Blue ZHP Sedan @ 210k
    Dead due to damaged valve. We will save her soul for future use, but the body will go to car heaven...or another owner...who may or may not turn her into a race car...

  9. #19
    Join Date
    Jan 2019
    Location
    Tampa, FL
    Posts
    196
    Deathtrap, since you're down so much on power, you could have clogged cats. Did you pull the O2s to release some pressure to see if it ran any better?

    rkneeshaw, I realized that you had clutch work done when your issue started. I wonder if you have an exhaust leak from dropping the exhaust that is leaning out your O2s and causing the misfire.

    There was another thread on here recently of someone having a higher RPM misfire in an engine after an engine swap. One bank was leaning out. It was fine before the swap. I suggested maybe a leak at the exhaust manifold letting oxygen into the exhaust and fooling the O2. Haven't heard back yet.

    You can always smoke test the exhaust to look for leaks. That may also go for clogged cats, since if you don't get much flow out an O2 bung then somethings clogged.

    Based on my 2800rpm stumble experience and the 4k dip, these engines seem extremely sensitive to O2 readings and knock sensor stuff. In my case, a DME update to the newest software solved all of those issues by loosening the O2 tolerances and clearing the knock adaptations. You guys may just have something slightly off causing the DME to freak out.
    '04 330i ZHP sedan | Mystic blue | Alcantara | 6MT | 111k
    '98 740il | Schwartz 2 | Sandbeige | 5AT | 238k | lowered on Bilsteins w/ B&G springs
    '00 540i sport | Titanium silver | Black | 5AT | 120k
    '85 Mustang GT convertible | Medium charcoal metallic | Gray | 5MT | 215k | one owner, all original

  10. #20
    Racer,

    I believe I have clogged cats as well. My ZHP spits out a lot of soot sometimes. I had my wife rev the engine to 2000 rpms, I put my hand by the tail pipe and the amount and pressure of the exhaust was very weak.

    2, I recall having a rattling noise upon cold start. Guess what? That noise is no longer present. That may have been the cat internals finally giving up and finding a nice resting spot in the exhaust.

    Definitely time for headers....

    Sent from my Pixel 2 XL using Tapatalk
    -Corey

    2003 Blue ZHP Sedan @ 210k
    Dead due to damaged valve. We will save her soul for future use, but the body will go to car heaven...or another owner...who may or may not turn her into a race car...

Page 2 of 4 FirstFirst 1234 LastLast

Similar Threads

  1. Help/Advice-misfire (long-ish)
    By Washburn in forum Mechanical | Troubleshooting
    Replies: 12
    Last Post: 03-29-2015, 08:02 AM
  2. P0302 cyl 2 misfire
    By Washburn in forum Mechanical | Troubleshooting
    Replies: 2
    Last Post: 03-07-2015, 04:55 PM
  3. Cyl 6 Misfire after repeated short run times
    By CarbonZHP in forum Mechanical | Troubleshooting
    Replies: 49
    Last Post: 10-22-2014, 11:32 AM
  4. Misfire cylinder 1 & 5
    By PirateZHP in forum Mechanical | Troubleshooting
    Replies: 24
    Last Post: 12-04-2013, 10:26 AM
  5. Misfire cylinder 1
    By Tampa330i in forum Mechanical | Troubleshooting
    Replies: 14
    Last Post: 04-02-2013, 09:41 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •