Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: New Android head unit no Audio

  1. #1
    Join Date
    Oct 2018
    Location
    Vancouver
    Posts
    27

    New Android head unit no Audio

    Hello everyone,

    I just attempted to install a 9" android head unit from Eonon (GA9150KW), I got it wired up and turned it on for a test and no audio! So looking online I found that the Harmon Kardon amp might be my problem.. Apparently it needs a 12 volt signal to prompt it to power on. I have seen a few threads that mention this but don't go into great detail. One said to splice a 12 volt power source and connecting it to the blue and White wire.... Anyone have more experience with this? I'm am not sure what wire would be the amp signal. Thanks!
    2006 - black sapphire metallic - convertible - 6 speed manual

  2. #2
    I don't have specific knowledge of how the HK amp works, but with normal aftermarket amps there is a "turn-on wire" that is usually tapped from the radio's ACC power line.

    On the schematic I see a BLU/WHT wire that connects from the amp to the front left midrange...but they don't list wire functions in here.
    Quote Originally Posted by lucifer1
    You will notice quickly it is not a Honda. Welcome to BMW, for those who like working on cars just to keep it functioning.

  3. #3
    Join Date
    Nov 2016
    Location
    Charlotte, NC
    Posts
    2,110
    Post a pic of the wires coming out of the back of the headunit. I know what you need to connect, but it's been so long that I need to see it to jog my memory and point it out.

  4. #4
    Join Date
    Oct 2018
    Location
    Vancouver
    Posts
    27
    Thanks for the help! I took some pics and will post them tonight when Iím off work.
    2006 - black sapphire metallic - convertible - 6 speed manual

  5. #5
    Join Date
    Oct 2018
    Location
    Vancouver
    Posts
    27
    Quote Originally Posted by DeathTrap View Post
    I don't have specific knowledge of how the HK amp works, but with normal aftermarket amps there is a "turn-on wire" that is usually tapped from the radio's ACC power line.

    On the schematic I see a BLU/WHT wire that connects from the amp to the front left midrange...but they don't list wire functions in here.
    Guess its not that blue and white wire then lol(they may have meant on the supplied harness adapter?), but where did you find the schematics? They could be useful for this.. Thank you!

    Quote Originally Posted by ZHPizza View Post
    Post a pic of the wires coming out of the back of the headunit. I know what you need to connect, but it's been so long that I need to see it to jog my memory and point it out.
    Hey ZHPizza, I will post some pics below showing how it is currently hooked up. Thanks so much for your help BTW! Also in the second pic I circled a plug that I didn't plug in anywhere. The how to videos I watched on youtube as a tutorial don't mention this small plug below the main one nor did the instructions with the new unit.(see red circle pic #2)


    Name:  IMG_3378.jpg
Views: 52
Size:  157.6 KB
    Name:  IMG_3377.jpg
Views: 52
Size:  328.4 KB
    Name:  IMG_3379.jpg
Views: 52
Size:  91.2 KB
    2006 - black sapphire metallic - convertible - 6 speed manual

  6. #6
    Join Date
    Nov 2016
    Location
    Charlotte, NC
    Posts
    2,110
    Well that blue wire that is connected is the one that I was going to be looking for. The unused plug on the connector is normal though. No worries there. Looks like you don't have the HK system? The car didn't come with navigation, right?

  7. #7
    Join Date
    Nov 2014
    Location
    Portland, OR
    Posts
    9,064
    Quote Originally Posted by ZHPizza View Post
    Well that blue wire that is connected is the one that I was going to be looking for. The unused plug on the connector is normal though. No worries there. Looks like you don't have the HK system? The car didn't come with navigation, right?
    I thought all ZHPs came with HK, no?

  8. #8
    Join Date
    Nov 2016
    Location
    Charlotte, NC
    Posts
    2,110
    Quote Originally Posted by BMWCurves View Post
    I thought all ZHPs came with HK, no?
    I dunno. I don't see the little spatialization speaker button. Maybe they didn't put it in the drop tops?

  9. #9
    The Bentley manual has a few wiring diagrams. I can grab some pics if needed, but I think these guys are already on top of it.
    Quote Originally Posted by lucifer1
    You will notice quickly it is not a Honda. Welcome to BMW, for those who like working on cars just to keep it functioning.

  10. #10
    Join Date
    Oct 2018
    Location
    Vancouver
    Posts
    27
    Hey guys thanks for all the feedback! Got an update on the 9" eonon droid head unit, I was emailing back a forth with eonon's support team, they were actually fairly helpful.. They asked for pictures of the front and back of my wiring harness showing the pins and cables and anyways they sent me this video, basically there is a option buried in the setting to turn on the external amp!........... Wish that little tidbit was in the instructions because I put my car back to stock and was ready to send the head unit back. So I guess I will reinstall it and will give an update this weekend. If it works out maybe I will do a review on it.
    Last edited by TripleBlackZHP; 01-09-2019 at 08:46 PM.
    2006 - black sapphire metallic - convertible - 6 speed manual

Page 1 of 2 12 LastLast

Similar Threads

  1. Review: Xtrons PB7646BAP Android 6.0 Head Unit - Pic Heavy
    By az3579 in forum Product and Storefront Reviews
    Replies: 111
    Last Post: 07-16-2018, 08:47 AM
  2. Xtrons PB7646BAP Android 6.0 Head Unit
    By Cadeez in forum Audio | In Car Entertainment (ICE)
    Replies: 16
    Last Post: 02-23-2018, 12:44 AM
  3. Use of factory GPS antenna with Android head units?
    By SaltyNC in forum Audio | In Car Entertainment (ICE)
    Replies: 5
    Last Post: 12-30-2017, 01:15 PM
  4. Hizpo Android 7.1 head Unit
    By nextelbuddy in forum Audio | In Car Entertainment (ICE)
    Replies: 9
    Last Post: 10-16-2017, 09:35 AM
  5. 05 Avin multimedia head unit
    By phillipjfry in forum Audio | In Car Entertainment (ICE)
    Replies: 6
    Last Post: 03-16-2017, 08:43 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •