Page 3 of 6 FirstFirst 12345 ... LastLast
Results 21 to 30 of 51

Thread: '04 AW/Blk coupe project (engine replacement first)

  1. #21
    Damn, sorry to hear about your accident! Looks very similar to the one I was in. Car looks great after though!


    I still need to track down a better hood and want to replace my front bumper but need to make some more $$$ first.

  2. #22
    Join Date
    Nov 2017
    Location
    Irvine, CA
    Posts
    130
    Quote Originally Posted by GotZHP View Post
    Damn, sorry to hear about your accident! Looks very similar to the one I was in. Car looks great after though!


    I still need to track down a better hood and want to replace my front bumper but need to make some more $$$ first.
    Thanks! My friends did a great job with it. I'm very thankful for them and for no injuries from the accident.

    I feel you on the $$$, hope you can get it done; I'll be looking out for your updates!

  3. #23
    Join Date
    Nov 2017
    Location
    Irvine, CA
    Posts
    130
    So it's been a while since I've updated this thread, frankly there wasn't anything to update. More parts came in and finally some progress. Lots of photos. Here we go:

    Replaced the ICV gasket/tube, unsure if it was leaking (probably not), but I figured why not change it:



    I forgot to get the o-rings the first time around for the VANOS solenoids, got 'em in this box of parts:



    Got these parts in and this side of the engine is looking like an engine again:



    Some Redline for the diff and some new plugs. I made an utter mess of it while draining the old fluid, about 3/4 of it went onto my arm and over the ground... quite a mess. Cleaning the mess up was not the funnest way to spend an hour, but it had to be done - no photos of the mess, too embarrassing and I was too oily to handle the camera.



    At 99,7xx miles and with the exhaust off I figured I'd change the CSB and the guibo. Both looked good, but the "while I'm in there" habit got the best of me. I forgot to take a photo of the new CSB and new butyl strip. It's weird, my m3 didn't have butyl on the CSB.









    I also took the time to change the driveshaft centering bushing. Inner diameter was too small for a pilot bearing puller and slide hammer. Bentley's says to pack with grease and to let the grease push it out. I didn't want to waste or clean up a bunch of grease. I've heard of people using wet bread for the pilot bearing too, but I didn't want to clean or waste bread. I just used bits of paper towel and water. An 8mm deep socket (with bits of wet paper towel to plug it up), an extension and a few hits with a rubber mallet did the trick:





    Ok, onto the injectors. I was too cheap to send them in for a cleaning, so I shade-tree'd it.

    First, remove the old injector filter. Insert a #10 sheet metal screw a few threads deep, and some twisting and tugging worked:



    Injector on the left has old filter basket, the one on the right is after its removal:


    Then in a manner similar to what GotZHP did, I rigged something up for cleaning the injectors. Carb cleaner, some shrink tubing, a 9v battery and leads to cycle the injector, and some spraying onto my garage floor... ghetto style:



    Old o-rings and filters out, new ones ready to go in. About $13 for the set from ebay. O-rings in the kit are supposedly viton.



    Ready to go back in:



    and back in:


    I keep forgetting to take photos while I'm working. But the new exhaust studs came in and the headers and new heat shield/gaskets went on with new header copper nuts:



    New O2 sensors. At about 100k miles they're due to be changed - they fail progressively from what I've heard.



    Before rejoining the engine and transmission I decided to change the torque converter-to-trans seal. Here's the old one:



    Torque converter side (Old on the left, new on the right):



    Trans side (old left, new right):



    New steering coupling while I'm at it. This was a mistake at this point, those that's done this job will know what I'm talking about..



    Now the big stuff... engine and trans going back in. This was a bitch of a job. Extra hands are needed, I enlisted the help of mom and dad. Not only were they great help, but I think they had a lot of satisfaction in being able to help with this project. Having removed the trans on my m3 for a clutch/flywheel replacement I can say it's infinitely easier to properly torque the engine/trans mounting bolts while the units are out of the car - duh!. lol.





    Two photos and it's in, voila! Yea, right. I wish it were that easy. It probably took a solid hour (I kept the AC system sealed so that was an added headache). Time for the subframe/front axle assembly to go back in.





    I still need to double-check some nuts and bolts as well as reconnect the shifter linkage, but the drivetrain is back in the chassis.

    Some shots from underneath... will need some cleaning too.





    I'm exhausted, so things will have to wait until tomorrow. Feels good to make some progress. More to follow...

  4. #24
    Join Date
    Nov 2016
    Location
    Charlotte, NC
    Posts
    2,493
    Now that's some progress! Damn!

  5. #25
    Join Date
    Nov 2014
    Location
    Portland, OR
    Posts
    9,194
    Quote Originally Posted by ZHPizza View Post
    Now that's some progress! Damn!
    +1

  6. #26
    Join Date
    Nov 2017
    Location
    Irvine, CA
    Posts
    130
    ^ ^ thanks fellas.

    Ok, update time. Some small stuff, some bigger stuff; progress!

    Some small stuff, like the vacuum hose ends from the "F" connector and the fuel pressure regulator.

    Before:


    After:





    These small items bring me such joy to replace and "get right." lol. I have some fuel hose coming in to replace those hoses from the fuel filter. They don't seem to be leaking, but the rubber is surely degraded since they feel gummy.

    I saw this exposed wire from the AC compressor, some shrink tubing with some meltable sealant inside (Harbor Freight "marine" version) should suffice:




    It was tricky, but I had to split the shrink tubing, and then use a bunch of small zip ties to hold it closed while I handled the heat gun. The results should suffice:


    Up next, the positive jump-start terminal. The cap was broken at the hinge, it really bugged me so I fixed it.



    Some more small stuff, the MAF o-ring:


    Out with the Purolator air filter the PO used, and in with a MANN OEM filter. The Purolator was very very clean, but it bugged me so out it went:



    Cooling system parts ready to go:



    A little "macro" shot to show the status. Lots of blue tape with notes of Low Fluids / No Fluids.



    Power steering hoses, just cleaning them up and replacing the seals (o-rings and crush washer). First up, the high-pressure hose at the power steering pump. I double checked and realized there should only be a o-ring and no crush washer so the washer was removed from the pump-side:



    The o-ring was misshapen, instead of round it's now conical. Unfortunately I didn't take a photo of the new one, but just imagine the conical shape as a regular donut shape of an o-ring. lol



    Transmission filter is next. The nasty transmission oil still dripping out.



    Remnants of the old fluid, no doubt it's original (99,721 miles):



    New fill and drain plugs:


    No photos of the Redline D4ATF going in, too busy pumping it in and way too oily to handle a camera/phone. Just imagine clean red fluid.
    The process? I turned the crank about 30-40 times after topping off the trans using the transmission oil pump to circulate new fluid through the torque converter, the cooling line, and radiator mounted cooler. After hand turning the engine 30-40 times I topped off the trans fluid again, usually 1/2-2/3 qt each time. This process took forever... I repeated the crank/top off process until clearer red fluid was coming out the trans cooler outlet. Then reconnected the hose leading back to the trans and repeated the process another time to fill that return hose. I got as much of the old fluid out as possible and then closed it up for now (will need to recheck level and top off after warming up).

    The last time I did this for a friend's ZHP I just used started the car for a few seconds then shut off to top-off. I also shifted the trans from P through D1. This car wasn't running so this method will have to suffice. But boy, it took a long time and so many turns of the crank. I'm exhausted, but as a bonus I got quite a workout and will probably sleep well tonight.

    Onto the rear brakes, they needed replacing. Went with Zimmerman rotors and Textar pads. The Zimmermans feel much better quality than the Centrics I bought for my M3.

    Passenger side:


    Driver's side:


    Exhaust and heat shield is next. I used some Super Clean and a brush to get some grime and old oil off first. I kept my OCD in check this time. Sometimes good enough is good enough.





    I took a wire wheel to knock off some rust from the inconel header-to-exhaust studs and the flange faces. Then put some copper anti-seize on the threads before installing the exhaust with new gasket and nuts. For a one-man operation a transmission jack is invaluable. The muffler placed on the jack helped to ensure a better alignment during reinstallation (sorry, no pics of the ghetto-rig).





    I think the underside is just about done. Will need to crawl back under to double check some items (e.g. trans fluid level after warm up, and change the fuel hoses at fuel filter inlet and outlet), but good for now.

    Replacing the aux fan and mechanical fan with an electric one. Thanks, Mark for selling me your extra one.



    Took the opportunity to spray down the backside of the air duct with some 303. Hopefully it'll keep it from cracking in the miles ahead. I love that 303 stuff.



    Back together:


    Last image, charging the battery with the trusty old CTEK - another brand I love. The battery will need replacing but at least this will get the car operational for now.



    These things took a few days, but feels good to make progress. I refilled the PS system (will need to turn the wheel L-R a few times when the car is running), no drips so far so that's a good, but real test will be under pressure - fingers crossed. Also, I filled the cooling system with 50% BMW coolant and distilled water and let it circulate through the heater core. 2 gallons in, so just a final bleed when the car's running. No drips yet, so the o-rings and new parts seem to be working ok. Again, the real test will be when everything is pressurized and heat cycled. Fingers crossed.

    A big thanks to all those who post and update their project threads, browsing those definitely helps me to push on. And it's great to see enthusiasts putting in the love to keep these older cars on the road. They might be old, but I think BMW really hit a sweet spot with the e46 (all variants. This can be said about the e39 too, another fantastic car of this era, especially the m5).
    Last edited by Will; 04-23-2019 at 08:34 PM. Reason: Words and stuff

  7. #27
    Join Date
    Jan 1970
    Location
    Southern California
    Posts
    16,825
    Nice werk!

    Sent from my SM-G955U using Tapatalk
    Randeaux/Rando/John/jr - '06 Cic ZHP; Southern California
    "ZHP or not, I still like you"


    ZHP Performance Package, Cold Weather Package, Leather, Jet Black/Black/BlackCube, NAV
    ESS Stage 1 Twin Screw Supercharger, Sprint Booster, BMW Perf Intake, Magnaflow Exhaust, Dinan TB & STEP S/W, Ground Control Coilovers, UCC Sway Bars, Apex EC-7 18x8.5 ET38
    Dynavin D99+, Hardwire V1 (w/V1 Connection), BSW Stage 1 Speakers, Kicker Amp/Subwoofer
    BMW Performance Strut Brace, Orion V2 Angel Eyes, No-holes License Plate, SMG Paddle Shift Mod, Besian VANOS, Gold DISA, Fan Delete, M3 Side Mirrors
    Note: Actual car no longer resembles signature picture

  8. #28
    Join Date
    Nov 2016
    Location
    Charlotte, NC
    Posts
    2,493
    Damn dude you're killing it. Thanks for sharing your progress here.

  9. #29
    Join Date
    Nov 2017
    Location
    Irvine, CA
    Posts
    130
    ^ ^ Thanks fellas.

    A little more progress today, I can start to see a glimmer of light at the end of the tunnel...

    New fuel filler cap. The 15 year old original rubber o-ring was nicely cracked around the perimeter, so with my last parts order I just got an OEM unit - got one for the m3 while I was at it too.

    Old vs new:


    After some light cleaning of the filler pot (rubber surround), I hit it with some 303. Just a gratuitous picture of it installed:


    Ok, this one is a little weird, but progress nevertheless. When initiating the engine replacement my brother and I thought we needed to remove the hood for clearing the hoist arm, so we began to disconnect the windshield washer nozzle wires. Unfortunately, we cut a couple wires when unbundling the wires from under the tape. Bummer. but it can be fixed so I got it done today.

    The bundle:


    The cut wires:


    The fix (crimps and some shrink tubing):


    Protecting the other wires from the heat gun:


    After the heat gun:


    Taped up the bundle:


    I guess I'll find out if I connected the correct wires to each other. I think I got it, though. Used a little deductive reasoning to match up which ones matched (basically, as I unbundled the tape I took note of which cut ends were closest to each other... you know, MacGyver stuff. lol).

    That's it for now. Thanks for viewing; push on with your projects!

  10. #30
    Join Date
    Feb 2013
    Location
    Austin TX
    Posts
    5,486
    Looks good, man. Keep 'em coming.
    2005 IR / black / 6MT
    148,000 miles

Page 3 of 6 FirstFirst 12345 ... LastLast

Similar Threads

  1. Replies: 290
    Last Post: 10-03-2019, 08:29 AM
  2. Engine Replacement
    By SureShot434 in forum Performance
    Replies: 104
    Last Post: 06-25-2019, 05:34 PM
  3. Just joined; '04 coupe AW/Blk project car
    By Will in forum New Members (or older members who have not introduced themselves)
    Replies: 10
    Last Post: 11-30-2017, 07:06 PM
  4. Lorenzo's ZHP Coupe Project
    By Lorenzo in forum Projects
    Replies: 60
    Last Post: 02-07-2016, 10:05 AM
  5. Engine and Transmission Mount Replacement
    By Hornung418 in forum Maintenance
    Replies: 12
    Last Post: 12-12-2012, 05:31 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •