Page 3 of 6 FirstFirst 12345 ... LastLast
Results 21 to 30 of 54

Thread: Ed's Mystic ZHP Project and Maintenance Log

  1. #21
    Join Date
    Jan 1970
    Location
    Branford, CT
    Posts
    15,434
    Quote Originally Posted by racer2086 View Post
    It just looks odd to me having the white lights up front and the ambers in the back. Maybe I'll get used to it.
    Yeah, someone started to convert it to euro lights and either forgot to do the rears or just couldn't finish...
    You might as well finish it off with the proper RCR's.
    BP
    2005 330i ZHP / 6MT
    Imolarot / Naturbraun



    It's not the car you drive, it's how you drive it.

  2. #22
    Join Date
    Jan 2019
    Location
    Tampa, FL
    Posts
    111
    RCRs? What's that stand for?
    '04 330i ZHP sedan | Mystic blue | Alcantara | 6MT | 111k
    '98 740il | Schwartz 2 | Sandbeige | 5AT | 238k | lowered on Bilsteins w/ B&G springs
    '00 540i sport | Titanium silver | Black | 5AT | 120k
    '85 Mustang GT convertible | Medium charcoal metallic | Gray | 5MT | 215k | one owner, all original

  3. #23
    Join Date
    Jan 1970
    Location
    Branford, CT
    Posts
    15,434
    Quote Originally Posted by racer2086 View Post
    RCRs? What's that stand for?
    Red/Clear/Red, the euro tails. Like mine:

    BP
    2005 330i ZHP / 6MT
    Imolarot / Naturbraun



    It's not the car you drive, it's how you drive it.

  4. #24
    Join Date
    Oct 2016
    Location
    Sydney, Australia
    Posts
    122
    I actually want to go in the opposite direction with my car. I want RYR for rears, and amber turn signals up front... I guess that's because Euro is what we have down under.

    '03 325i 6MT Individual - Estoril Blue

  5. #25
    Join Date
    Jan 2019
    Location
    Tampa, FL
    Posts
    111
    I'd swap with you, but the shipping is probably as much as new lights!
    '04 330i ZHP sedan | Mystic blue | Alcantara | 6MT | 111k
    '98 740il | Schwartz 2 | Sandbeige | 5AT | 238k | lowered on Bilsteins w/ B&G springs
    '00 540i sport | Titanium silver | Black | 5AT | 120k
    '85 Mustang GT convertible | Medium charcoal metallic | Gray | 5MT | 215k | one owner, all original

  6. #26
    Join Date
    Oct 2016
    Location
    Sydney, Australia
    Posts
    122
    Quote Originally Posted by racer2086 View Post
    I'd swap with you, but the shipping is probably as much as new lights!
    Very true. To buy new is ridiculous

    Sent from my SM-N960F using Tapatalk

    '03 325i 6MT Individual - Estoril Blue

  7. #27
    Join Date
    Jan 2019
    Location
    Tampa, FL
    Posts
    111
    Just an update. I took both passenger door panels off to figure out the water leaks. Figured it had to be the vapor barriers. Sure enough, definitely was. The previous repair of the right front window regulator didn't even come close to getting the vapor barrier on right. It was flopping in the wind. The rear right only had a corner off that seemed to be just from age and maybe heat. It debonded and left the corner detached. Also found out they used a Taiwanese regulator on the front right. Ugh. I guess I'll just wait until it breaks.

    The butyl on these vapor barriers is hard to get a solid, perfect seal on just pressing it back together. I don't want to have to use new butyl and glob that much more on there. I have a trick to getting the old butyl clean and super sticky, so the vapor barrier resticks like glue and seals great. I fold up a paper towel and spray 3M adhesive cleaner on it. I dab that wet paper towel all along the butyl surface on the door frame and on the vapor barrier. Give it a minute to dry and then press the two pieces together firmly and evenly. The buytl will fuse together and you will not be able to peel the vapor barrier off easily. That's how you know it's sealed. Done. Works great on all BMWs. Been doing this on my 7 for a while.







    Next on the list is to pull the driver's door panel, check the plugs for the mirror, switch, and tweeter and see if any are mixed up or unplugged. I'll check the vapor barrier while there. I need to also pull the mirror trim and check the rain sensor. Hopefully it's just unplugged. If not, I'll have to get INPA going and reinitialize it.

    I'm out of town for a wedding but will pull the MAF when I get back and go for a drive. The SES light goes on and off based on the day. Depending on the day, I can feel the car struggling between 2500-3000 rpm. I'll smoke the intake and check for leaks. It's seriously down on power on the highway inside that RPM band.
    '04 330i ZHP sedan | Mystic blue | Alcantara | 6MT | 111k
    '98 740il | Schwartz 2 | Sandbeige | 5AT | 238k | lowered on Bilsteins w/ B&G springs
    '00 540i sport | Titanium silver | Black | 5AT | 120k
    '85 Mustang GT convertible | Medium charcoal metallic | Gray | 5MT | 215k | one owner, all original

  8. #28
    Join Date
    Jan 2019
    Location
    Tampa, FL
    Posts
    111
    Time to update after some more work done to the ZHP. Some good news and some bad.

    Went to the junkyard and scored two front tweeters, a rear midrange, auto dimming mirror, rain/light sensor and prism, passenger side AL projector and reflector, some trunk tools, a rear ash tray in great shape, a driver's door mirror with ribbon cable in Mystic Blue, all the pieces for the alarm retrofit, a new map light, and a few other things for a grand total of $104. Bam!

    Driver's door:
    After fixing the two passenger door vapor barriers, I pulled the driver's door panel. I found nothing wrong with the mirror or speaker connections. Darn. I also looked at the window regulator because the window would go up so slow for the bottom half of travel and then get better. It appears the rear regulator track is broken and the cable is out of it. So the window is going up and down on the front track and binding in the seal as it goes up, until is rises to the point where things even out. Guess it's time for a new regulator.

    Speakers:
    I tried out the new rear speaker, but it appears that there is some other problem. Both my original speaker and the new one work, but are very quiet. Now, I'm wondering if this is a radio or amp problem? My radio knob acts all crazy also...

    I put all the alarm pieces in and coded the car with DIS. So now the alarm works. Yay!

    The rain/light sensor I got is bad...after getting home I can hear something rattling around. And out came some small SMD parts that look like capacitors. So need to try to get a new one of those.

    I'm not sure what to do with the AL projector and reflector. I would love to just put the reflector in my ZKW light, but I'm not sure it will fit and it is more involved due to the bi-xenon solenoids. I hate these damn headlights. This shouldn't be an issue.

    Also, while back in the trunk area putting in the tilt sensor for the alarm, I noticed another loose hanging wire that seems to be coming from up in the rear deck area. Anyone know what this is for? (pic below)



    '04 330i ZHP sedan | Mystic blue | Alcantara | 6MT | 111k
    '98 740il | Schwartz 2 | Sandbeige | 5AT | 238k | lowered on Bilsteins w/ B&G springs
    '00 540i sport | Titanium silver | Black | 5AT | 120k
    '85 Mustang GT convertible | Medium charcoal metallic | Gray | 5MT | 215k | one owner, all original

  9. #29
    Join Date
    Feb 2013
    Location
    Austin TX
    Posts
    5,265
    That was an amazing find … all those parts for only $104. GL on fixing the issues you mentioned.
    2005 IR / black / 6MT
    146,000 miles

  10. #30
    Join Date
    Oct 2016
    Location
    Sydney, Australia
    Posts
    122
    That wire's for the battery tender they use for before delivery to a customer. Or some part of that system.

    Sent from my SM-N960F using Tapatalk

    '03 325i 6MT Individual - Estoril Blue

Page 3 of 6 FirstFirst 12345 ... LastLast

Similar Threads

  1. Replies: 277
    Last Post: 05-13-2019, 04:56 PM
  2. Alpine White ZHP Project/Maintenance
    By dkmcclelland in forum Projects
    Replies: 63
    Last Post: 01-03-2018, 06:13 PM
  3. Replies: 594
    Last Post: 11-09-2017, 08:07 PM
  4. Holden's e36 ///m project/maintenance thread
    By hcbeck2689 in forum Projects
    Replies: 16
    Last Post: 11-19-2016, 05:06 AM
  5. FinanceGuy's Maintenance/Project thread -- 08 E70
    By TheFinanceGuy in forum Projects
    Replies: 34
    Last Post: 11-05-2015, 06:48 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •