Page 2 of 2 FirstFirst 12
Results 11 to 18 of 18

Thread: Single deck OEM style head unit replacement?

  1. #11
    Quote Originally Posted by GotZHP View Post
    Lol, my power button shit the bed too.

    Can you link the parts for repair, I need to do it too
    https://www.bavtekinc.com/do-it-yourself/e46-cd53

    or order through ebay for free shipping

  2. #12
    I went ahead and ordered the GROM BMWSU3, along with the bluetooth extension, and the USB charging and 3.5mm aux input.

    I paid $200 shipped for everything.

    The Dension would have been cheaper by about $50, but decided to go with the GROM because... I don't really know why. I saw a video showing alternator whine on the dension. Also this video shows it not displaying text (although officially text is supported?), and superior support by GROM, as Dension's U.S. vendor is this weird enfig site.

  3. #13
    I've had the GROM setup for about 3 or 4 years now (maybe even 5 or 6), and it's awesome. Song text is displayed, it's pretty quick, and you can use steering wheel controls. I do recommend updating the firmware as soon as you get it.

    Sent from my SHIELD Tablet using Tapatalk

  4. #14
    Quote Originally Posted by Chaplian View Post
    I've had the GROM setup for about 3 or 4 years now (maybe even 5 or 6), and it's awesome. Song text is displayed, it's pretty quick, and you can use steering wheel controls. I do recommend updating the firmware as soon as you get it.
    Thanks for the heads up; will do first thing

  5. #15
    Quote Originally Posted by Fried_Chicken View Post
    https://www.bavtekinc.com/do-it-yourself/e46-cd53

    or order through ebay for free shipping
    Thanks mate! I need to fix my power button and decide on a final location for my Aux input to be mounted. Really should get a Bluetooth adapter too so I can take calls in the car.

  6. #16
    Just finished the install of the GROM (what a terrible name).

    They said something like 2 hours... forget it, more like 5.
    Granted, I did also add the USB flush mount at the bottom where the DSC and DSP buttons are. I have to say it looks o.k. Ideally I'd want it recessed in there, but I don't see how that would have been feasible. It's in there solid, so I'm not worried about it coming apart. I'm really annoyed that I installed the USB port the wrong way up, but that can't be changed. I definitely prefer hooking up my USB like this.

    Bluetooth calling works really well. I mounted the microphone in front of the gauge cluster. I did a test call at around 50 mph, and it's clear, both sending and receiving. Steering wheel buttons work too. Call accept is the up button, call decline is the down button.

    Overall I'm very happy with this unit for $200. There are a few small hickups that keep it from being perfect OEM BMW, but no dealbreakers.

    One unusual thing that happened (That's not related to the GROM) is the front left tweeter has stopped working. I double checked my wiring harness connection, and didn't see anything there. On my old head unit, I think the passenger side tweeter didn't work.

    Here's a picture of the flush-mounted USB:
    Name:  IMG_6281.jpg
Views: 39
Size:  1.89 MB

  7. #17
    Looks good! For your driver side tweeter, try reseating the connector to the head unit, and the connector in the trunk with the amp.

    If that doesn't fix it, the amp may have bit the dust. (That's what happened to my sedan.)

    Did you buy the behind the radio kit, or the trunk kit?

    Sent from my Pixel 2 using Tapatalk

  8. #18
    Quote Originally Posted by Chaplian View Post
    Looks good! For your driver side tweeter, try reseating the connector to the head unit, and the connector in the trunk with the amp.

    If that doesn't fix it, the amp may have bit the dust. (That's what happened to my sedan.)

    Did you buy the behind the radio kit, or the trunk kit?

    Sent from my Pixel 2 using Tapatalk
    Behind the radio kit. I already tried cleaning and reseating the head unit harness. I will try the trunk amp harness when I get a chance.

Page 2 of 2 FirstFirst 12

Similar Threads

  1. New Android head unit no Audio
    By TripleBlackZHP in forum Audio | In Car Entertainment (ICE)
    Replies: 22
    Last Post: 05-26-2019, 02:14 PM
  2. Xtrons PB7646BAP Android 6.0 Head Unit
    By Cadeez in forum Audio | In Car Entertainment (ICE)
    Replies: 16
    Last Post: 02-23-2018, 12:44 AM
  3. Hizpo Android 7.1 head Unit
    By nextelbuddy in forum Audio | In Car Entertainment (ICE)
    Replies: 9
    Last Post: 10-16-2017, 09:35 AM
  4. 05 Avin multimedia head unit
    By phillipjfry in forum Audio | In Car Entertainment (ICE)
    Replies: 6
    Last Post: 03-16-2017, 08:43 AM
  5. replacing stock head unit - coding?
    By KevinC in forum Audio | In Car Entertainment (ICE)
    Replies: 8
    Last Post: 05-17-2012, 09:49 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •