Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: First day using the heater, but heater only blowing warm/cold air on max

  1. #1

    First day using the heater, but heater only blowing warm/cold air on max

    Hi all,

    As the title suggests, today is probably the first day of the year that the heater of my 330Ci has been used. Before I bought it, it had been garage-kept as winter started. My heater, however, did not blow any hot air for a while. It got a bit warm in the center two vents but the drivers side vent remained cold. I also turned it off for about five minutes, and turned it back on to the same results.

    I also noticed that upon acceleration on the highway, the center vent air flow went a bit cold as well.

    Here is some further information,
    -The car has about 96,000 miles on it, I have put on about 4000 since I bought it in June.
    -I had the AC gas recharged in June.
    -Recently, whenever I would turn on and off the a/c maybe a few weeks ago, I noticed a slight crackling noice, like paper unfolding near the front where the windshield is around. I don't suppose that is too much.
    -When I turned on the heater, I had it at max 91 degrees, gradually increasing fan speed. Is it bad that I immediately went to 91?
    -On the highway, when I noticed the center vents go cold, I was accelerating from about 40 to 55mph.

    I can only assume the heater works well, since the car lived most of its life in Toronto. Any help and/or input would be greatly appreciated!
    1991 E30 Alpinweiß 325iX [SOLD]
    2005 E46 Sparkling Graphite Metallic 330Ci ZHP 6spd

  2. #2
    Join Date
    Feb 2013
    Location
    Austin TX
    Posts
    5,573
    I believe the e46 has a temperature knob like this one. Do you have it set to red ?

    Name:  knob.jpg
Views: 54
Size:  849.8 KB
    2005 IR / black / 6MT
    148,000 miles

  3. #3
    Quote Originally Posted by fredo View Post
    I believe the e46 has a temperature knob like this one. Do you have it set to red ?

    Name:  knob.jpg
Views: 54
Size:  849.8 KB

    Okay yeah feeling like a total idiot now. Does it also affect the drivers' side temperature too?
    1991 E30 Alpinweiß 325iX [SOLD]
    2005 E46 Sparkling Graphite Metallic 330Ci ZHP 6spd

  4. #4
    Join Date
    Oct 2017
    Location
    Amherst, NH
    Posts
    438
    mine looks like this... with the dial set to blue (cold)
    Attached Images Attached Images  
    - Pete

  5. #5
    Join Date
    Jan 1970
    Location
    Huntsville, AL
    Posts
    4,014
    What’s your engine temp running at??? It should be mid range. If it’s low you need a new thermostat. If it’s mid, it may be related to a heater control valve.

    Also need to check coolant level (COLD) and if it shows low, fill it and maybe bleed it.

    I can elaborate, if needed.


    Sent from my iPhone Xs using Tapatalk

    Dinan; Hign Flow Intake System, & Strut Tower Brace
    Turner Motorsports; Underdrive Power Pulleys
    Koni Sport, Bridgestone; Potenza RE-11, Coby Wheel
    Stewart High Performance Water Pump
    Hawk High Performance Street 5.0 Brake Pads
    Brembo Rotor

    The purposeful face of a formidable athlete:

    The spine-tingling 330i Performance Package.

    Purchased CPO on 12/23/2006 with 28,090 miles

  6. #6
    Thank you everyone, but it turns out I didn't have the center temperature knob moved at all. I guess this is what happens when you've never had that in a car.
    1991 E30 Alpinweiß 325iX [SOLD]
    2005 E46 Sparkling Graphite Metallic 330Ci ZHP 6spd

  7. #7
    Join Date
    Nov 2016
    Location
    Charlotte, NC
    Posts
    2,537
    Quote Originally Posted by Dano516 View Post
    Thank you everyone, but it turns out I didn't have the center temperature knob moved at all. I guess this is what happens when you've never had that in a car.
    All good - happens to everyone at some point. The Germans put that in so you can have warm air coming out of the floor to keep the cabin warm while cool air is blowing in your face to keep you alert. It's pretty nice.

    Sent from my Pixel 3a using Tapatalk

  8. #8
    Join Date
    Jan 2016
    Location
    Chicago area
    Posts
    1,744
    Quote Originally Posted by Dano516 View Post
    -When I turned on the heater, I had it at max 91 degrees, gradually increasing fan speed. Is it bad that I immediately went to 91?
    It shouldn't make a difference, when used like that. But you should set it to the temperature you want to get when using the auto setting. I keep mine at 60 for the winter.

  9. #9
    Join Date
    Jan 1970
    Location
    Branford, CT
    Posts
    15,664
    There is no need to set it to 91. Set it to a temperature you would feel comfortable with (ex: 70) and it'll automatically blow whatever temperature air and at whatever fan speed it needs to in order to reach that temperature and keep it there.

    Adjust whether you want it to blow hot or cold air with the slider instead. It's far easier than constantly adjusting the temperature.
    BP
    2005 330i ZHP / 6MT
    Imolarot / Naturbraun



    It's not the car you drive, it's how you drive it.

  10. #10
    Join Date
    Nov 2016
    Location
    Charlotte, NC
    Posts
    2,537
    Quote Originally Posted by holyc0w View Post
    It shouldn't make a difference, when used like that. But you should set it to the temperature you want to get when using the auto setting. I keep mine at 60 for the winter.
    Effing yeti over here gd

    Sent from my Pixel 3a using Tapatalk

Page 1 of 2 12 LastLast

Similar Threads

  1. Seat heater on by default
    By anandoc in forum BMW Coding
    Replies: 1
    Last Post: 01-13-2016, 10:45 AM
  2. Heater going bongos
    By alexandre in forum General -- ZHP Related
    Replies: 6
    Last Post: 01-21-2013, 09:27 PM
  3. Heater question--always cold air from top vents?
    By tomjonesrocks in forum Mechanical | Troubleshooting
    Replies: 5
    Last Post: 01-27-2012, 06:26 AM
  4. Block Heater
    By apridge in forum General -- ZHP Related
    Replies: 16
    Last Post: 11-19-2011, 10:40 AM
  5. Heater is not working properly
    By Linh in forum Mechanical | Troubleshooting
    Replies: 6
    Last Post: 12-03-2010, 03:30 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •