Results 1 to 2 of 2

Thread: Traction Control/Throttle Issues

  1. #1

    Traction Control/Throttle Issues

    An issue has popped up recently that has me really scratching my head. The car starts up and idles just fine, no codes checked with a basic Bluetooth obd2 scanner and the torque app. When I'm in 3rd gear or 4th gear at about 2500rpm if I stomp on it the TC light immediately comes on. It'll even do it if I slowly roll into the throttle. This doesn't seem to happen in lower or higher gears though. If I turn the TC and stability control off completely the power reduction due to the interpreted "loss of traction" goes away but it's like the throttle is erratic and sometimes stays on in higher rpms in 3rd and 4th gear. For example, if I'm in 3rd gear at 60mph and and let off, it'll still stay at that rpm for a second or two and then start coming down somewhat erratically with the engine braking. I do have a sprint booster v3 installed, but even with it off all the symptoms I mentioned are still there. I've disconnected and reconnected the battery to see if that would clear anything, but no luck. I've looked on what seems to be every forum or thread and some possible culprits could be a wonky ABS/wheel speed sensor or a bad throttle pedal, but I have yet to grab my multimeter and check. I'm going to take off the sprint booster to see if that fixes it but as far as I can tell the only thing that would be wrong there would be a faulty connection and I know from experience that an incomplete connection with the throttle pedal results in full limp mode. I'll get a video of my gauge cluster with the symptoms in the coming days if that helps. Any and all thoughts on what this could be are greatly appreciated.

    Sent from my SM-G965U using Tapatalk

  2. #2
    I took the sprint booster off completely and took this video of the aforementioned symptoms. I also failed to mention that I had a brake line burst and then replaced about 2 weeks before all this started happening. Maybe ABS module has some codes that need read, not quite sure though since the ABS light has never came on even when the line burst and my brake pressure went to almost zero.

    https://youtu.be/2IqdbQbCx7I

Similar Threads

  1. ZHP vs xi Traction Control
    By Reasoned1 in forum New Members (or older members who have not introduced themselves)
    Replies: 4
    Last Post: 11-13-2016, 04:52 AM
  2. traction control + brake light (in yellow) - what's up?
    By KevinC in forum Mechanical | Troubleshooting
    Replies: 9
    Last Post: 10-17-2013, 09:58 AM
  3. FYI: Traction control and brake lights on? Read this.
    By az3579 in forum Mechanical | Troubleshooting
    Replies: 6
    Last Post: 11-07-2011, 06:04 PM
  4. Brake and traction control lights on.
    By jjcools in forum Mechanical | Troubleshooting
    Replies: 7
    Last Post: 09-15-2011, 05:06 AM
  5. P1510: Idle Control Valve, Throttle Body or both?
    By Hornung418 in forum Mechanical | Troubleshooting
    Replies: 8
    Last Post: 04-30-2011, 05:28 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •