Page 2 of 2 FirstFirst 12
Results 11 to 14 of 14

Thread: Ball Joint Creak?

  1. #11
    Join Date
    Dec 2016
    Location
    Boston, MA
    Posts
    617
    Had a chance to pull the inner tie rod boots tonight; plenty of grease where the inner tie rods connect to the rack. No dryness that would suggest a metal-on metal condition. The steering operates fine; nothing indicating the rack or pump is bad. Again - PS reservoir was full and no indications of a leak from either the rack nor the hoses.

    Shot another video, this time without any help so I had to rig up a rope so I could be under the car and turn the wheel at the same time. Wanted to be able to turn the wheel with the car off, so I put two VCT tiles with a bit of grease between them under the tires so they would turn easily. (Trick I learned from racing and setting my own camber and alignments.) The video was just to show a friend how I did it, but without the engine noise of the first video itís a bit clearer.

    https://youtu.be/9CGhaHf_B9Q
    -Chris


  2. #12
    Join Date
    Dec 2016
    Location
    Boston, MA
    Posts
    617
    Bringing this to closure; It turns out the creak was coming from the spherical rod ends on the anti-roll bar end links. They’re worn and need replacement. I think I’m going back to the OEM-style end links because the rod ends don’t hold up to the abuse of public roads.

    Hard to believe such a loud noise was coming from the end links. Hope this info helps someone in the future...
    -Chris


  3. #13
    Join Date
    May 2020
    Location
    Toronto, ON
    Posts
    489
    Good to hear that you've solved it. It also confirms my thoughts that exposed spherical bearings should not be run on a street car, all the road grim and grit just wears them out quickly. I too plan on running OE-style adjustable endlinks, when it comes time.
    2004 BMW 330CI ZHP (well, technically ZAM)


  4. #14
    Join Date
    Nov 2017
    Location
    Irvine, CA
    Posts
    430
    Quote Originally Posted by cornercarver View Post
    Bringing this to closure; It turns out the creak was coming from the spherical rod ends on the anti-roll bar end links. They’re worn and need replacement. I think I’m going back to the OEM-style end links because the rod ends don’t hold up to the abuse of public roads.

    Hard to believe such a loud noise was coming from the end links. Hope this info helps someone in the future...
    Glad you diagnosed it, and thanks for updating the thread.

Page 2 of 2 FirstFirst 12

Similar Threads

  1. New OE Drive shaft Flex Joint (Guibo) & New OE Hardware
    By ///Mvious in forum ZHP-Related Parts & Accessories (no vehicle sales)
    Replies: 0
    Last Post: 10-13-2018, 05:27 PM
  2. Harbor Freight Ball Joint Service Kit....FCAB's?
    By WALSTIB in forum General -- ZHP Related
    Replies: 6
    Last Post: 10-05-2017, 08:50 PM
  3. (SOLD) Craftsman 26 in.(2 box set) Heavy-Duty Ball Bearing Top Chest - Red/Black
    By 330i ZHP in forum Miscellaneous (no vehicle-related items)
    Replies: 7
    Last Post: 09-29-2013, 06:47 PM
  4. Pirate Ship Creak...
    By Hornung418 in forum Mechanical | Troubleshooting
    Replies: 17
    Last Post: 03-24-2012, 11:59 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •