Results 1 to 5 of 5

Thread: Battery light, car died, did some further tests, now need help interpreting

  1. #1
    Join Date
    Oct 2014
    Location
    Alexandria, VA
    Posts
    139

    Battery light, car died, did some further tests, now need help interpreting

    Saturday I took a short trip into town to drop off glass recycling. Was almost there, and the battery light came on. I immediately turned around, and on the way back the light stayed on, then more lights came on, then the car lost throttle response, then it died. I had a neighbor come tow me the 3 blocks back home.

    Charged the battery, tested voltage with the car off (12.7), and on (around 14)--the car had cooled a bit at this point. Left it overnight, battery still 12.7, on was 14.1. Used the on-board computer (key to position 2, hold left ODO reset post, go to 19, then go to test 9) to show voltage while I'm driving. All good--14/14.1, dips and recovers when I hit window switches, AC, lights. Driving along for about 20 minutes, then pulled away quite quickly from a stop light, and bam, battery light comes on and voltage dips into the 12s. Get home, park it, rev it, and even at 5-6,000 RPM, it only goes up to 13.8. At idle it's 11-12.

    Go out this morning, use the computer, and it's 12.7 off and 14 on. I suspect if I drive it a while it'll go down again.

    Does this point to alternator? Battery seems to take and hold a charge fine.

    Thanks,

    Paul

  2. #2
    Join Date
    Feb 2011
    Location
    Lexington, KY
    Posts
    4,245
    Do you know the age of this battery? Could be a sign that it is on its' last leg. Perhaps an Autozone could help you test it, as well as your alternator.

    If the voltage is higher with the car ON, seems your alternator is doing its' job.

    Money on the battery.
    325i, 2005, 5MT, Silvergrey, leatherette, Sport package; CDV delete, KONI STR-T & KYB Excel-G, Weisslichts, Stewart H2O pump

    328i, 2010, 6MT, Spacegrey, dakota leather, M-sport packages; all stock
    http://s900.photobucket.com/user/othibau/media/Junesig.jpg.html][IMG]http://i900.photobucket.com/albums/ac208/othibau/Junesig.jpg

  3. #3
    Join Date
    Oct 2014
    Location
    Alexandria, VA
    Posts
    139
    Quote Originally Posted by Oli77 View Post
    Do you know the age of this battery? Could be a sign that it is on its' last leg. Perhaps an Autozone could help you test it, as well as your alternator.

    If the voltage is higher with the car ON, seems your alternator is doing its' job.

    Money on the battery.
    I was thinking the same thing, but the battery is only 3 years old, holds a charge, and when it's hot the alternator is only charging around 11-12v unless I rev it to 5-6k.

  4. #4
    Join Date
    Feb 2011
    Location
    Lexington, KY
    Posts
    4,245
    Ah, I missed the part although you said at 5 or 600 rpm you got 13.8 V. Maybe that is the sign of a weak alternator. Let's see what others think. Can you have the alternator tested?
    325i, 2005, 5MT, Silvergrey, leatherette, Sport package; CDV delete, KONI STR-T & KYB Excel-G, Weisslichts, Stewart H2O pump

    328i, 2010, 6MT, Spacegrey, dakota leather, M-sport packages; all stock
    http://s900.photobucket.com/user/othibau/media/Junesig.jpg.html][IMG]http://i900.photobucket.com/albums/ac208/othibau/Junesig.jpg

  5. #5
    Join Date
    Oct 2014
    Location
    Alexandria, VA
    Posts
    139
    I'm just going to go ahead and replace it. Ordered a new Bosch from FCP.

Similar Threads

  1. Battery Light
    By yj4x4 in forum Mechanical | Troubleshooting
    Replies: 4
    Last Post: 06-17-2015, 06:22 PM
  2. Red Battery Light HELP!
    By tayyib330i in forum Maintenance
    Replies: 8
    Last Post: 05-29-2014, 09:27 AM
  3. Battery light
    By Mr Paul in forum General -- ZHP Related
    Replies: 7
    Last Post: 04-25-2013, 06:55 AM
  4. Battery light
    By blablac in forum Mechanical | Troubleshooting
    Replies: 4
    Last Post: 06-14-2012, 03:12 PM
  5. Been a while, back for a bit, red oil/battery light on
    By MafiaAmor in forum Mechanical | Troubleshooting
    Replies: 19
    Last Post: 05-18-2012, 06:24 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •