Results 1 to 4 of 4

Thread: AC not activating

  1. #1
    Join Date
    Dec 2015
    Location
    Indianapolis, IN
    Posts
    55

    AC not activating

    Drove my car in to work this morning, no issues. Leave the office this evening and notice the climate control had switched to Celsius. I have it reverted to F but the AC button is not illuminating nor does the air get cool. Any ideas?

  2. #2
    Join Date
    Dec 2015
    Location
    Indianapolis, IN
    Posts
    55
    Turned out to be the climate control unit as I suspected. Replaced with used unit and AC works perfect again.

  3. #3
    Join Date
    Jan 1970
    Location
    Southern California
    Posts
    17,520


    Sent from my SM-G988U using Tapatalk
    Randeaux/Rando/John/jr - '06 Cic ZHP; Southern California
    "ZHP or not, I still like you"


    ZHP Performance Package, Cold Weather Package, Leather, Jet Black/Black/BlackCube, NAV
    ESS Stage 1 Twin Screw Supercharger, Sprint Booster, BMW Perf Intake, Magnaflow Exhaust, Dinan TB & STEP S/W, Ground Control Coilovers, UCC Sway Bars, Apex EC-7 18x8.5 ET38
    Dynavin D99+, Hardwire V1 (w/V1 Connection), BSW Stage 1 Speakers, Kicker Amp/Subwoofer
    BMW Performance Strut Brace, Orion V2 Angel Eyes, No-holes License Plate, SMG Paddle Shift Mod, Besian VANOS, Gold DISA, Fan Delete, M3 Side Mirrors
    Note: Actual car no longer resembles signature picture

  4. #4
    Join Date
    Feb 2013
    Location
    Austin TX
    Posts
    6,206
    Quote Originally Posted by Hoonin88 View Post
    Turned out to be the climate control unit as I suspected. Replaced with used unit and AC works perfect again.
    Glad to hear you fixed it.
    2005 IR / black / 6MT
    150,000 miles

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •