Results 1 to 7 of 7

Thread: Turn signal problem

  1. #1

    Turn signal problem

    Hey guys, I have a 05 ZHP and Im having some problems (never not having problems with a e46).

    My turn signals went out the other day. The stalk doesn't work, when I push the emergency flashers nothing comes on (hazard button light blinks though), also pressing the key fob does nothing. Also the passenger mirror no longer tips down in reverse.

    As far as I can tell there is no turn signal relay or fuse. Does anyone know about this problem?

    Thanks

    05 ZHP 6MT Sedan Titanium Silver

  2. #2
    Join Date
    May 2020
    Location
    Toronto, ON
    Posts
    634
    It's fine, par for course with our make of cars as people know what to expect






























    lol I know that joke's pretty lame but I had to do it
    Sorry I don't actually know
    2004 BMW 330CI ZHP (well, technically ZAM)


  3. #3
    Join Date
    Dec 2019
    Location
    Raleigh, NC
    Posts
    417
    My turn signal bulbs burn out every couple of months for some reason. All my other lights last forever. It's probably some common electrical issue or the car trying to tell me that I don't need them. Probably the latter.
    330i Base | Mysticblau | Slicktop | 6MT

  4. #4
    Join Date
    Jan 2016
    Location
    Charlotte, NC
    Posts
    16
    These cars have turn signals?

  5. #5
    Join Date
    Jul 2016
    Location
    Austin Texas
    Posts
    236
    Lol @ the turn signal jokes.

    Have access to a good scan tool? From my experience, no turn signals/hazards indicate a possible instrument cluster issue. Any other oddities there? Another possibility is the k-can bus. When I installed a new set of seats in my e46, I left a canbus wire uncapped by accident. It periodically grounded out against the seat, leaving my cluster unresponsive.
    2005 Jet Black ZHP Sedan "Adriana" || TunedByDaniel || BMW Alarm + Fuel Lock || ORION V4s || Eagle Eyes || 435i Coupe Sport Seats || Perforated Leather X5 M-Sport Wheel || FLOW Designs Lip

  6. #6
    Join Date
    Jan 1970
    Location
    Lexington, KY
    Posts
    4,460
    Wasn't there a recall on some taillight wiring several years ago? Maybe inspect the wires going to the bulbs. Check to see if bulbs are working (continuity check with a volt/ or ohm meter).
    325i, 2005, 5MT, Silvergrey, leatherette, Sport package; CDV delete, KONI STR-T & KYB Excel-G, Weisslichts, Stewart H2O pump

    328i, 2010, 6MT, Spacegrey, dakota leather, M-sport packages; all stock
    http://s900.photobucket.com/user/othibau/media/Junesig.jpg.html][IMG]http://i900.photobucket.com/albums/ac208/othibau/Junesig.jpg

  7. #7

    Turn signal problem

    Quote Originally Posted by usinjin View Post
    Lol @ the turn signal jokes.
    I was just thinking blinker fluid was low




    This is what I found googling your issue regarding hazard lights and turn signals:

    There is only one "flasher" that controls the hazards and turn signals, its located under the steering column cover, pretty much right underneath where the turn signal lever goes into the collum. You will have to take off the steering wheel and undo two screws underneath and on top of the covers to remove them to get to the flasher.
    Last edited by cakM3; 04-07-2021 at 06:55 PM.

Similar Threads

  1. Front turn signal assembly
    By nsk040 in forum Lighting
    Replies: 7
    Last Post: 01-13-2019, 12:11 PM
  2. Front turn signal yes, running light no??
    By Poker_G in forum Lighting
    Replies: 9
    Last Post: 05-08-2018, 08:34 AM
  3. Turn signal rubber gasket
    By droman81 in forum Lighting
    Replies: 8
    Last Post: 09-07-2017, 08:56 AM
  4. Front corner turn signal sockets
    By brettbimmer in forum Lighting
    Replies: 4
    Last Post: 03-18-2013, 06:25 PM
  5. Turn Signal LEDs
    By tripod06 in forum Lighting
    Replies: 41
    Last Post: 07-23-2011, 06:07 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •