Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Electrical gremlin...

  1. #1
    Join Date
    Nov 2017
    Location
    Irvine, CA
    Posts
    636

    Electrical gremlin...

    I hate electrical problems, but I've got one that I hope someone has experience with and can help.

    TL;DR: could it be the Final Stage Resistor? I'd hate to replace it since it sucks to access.

    Car: 2003.5 e46 m3.

    Additional equipment:
    - BlueBus. I've had this since the first batch, and run the latest firmware. I've never had that IHKA problem even with old firmware.
    - Autodimming rearview mirror with compass and homelink, I believe from a e90. This was relatively new, but no problems with it after installation. Had for a few weeks without problems.

    In sequential order:

    - Noticed that the IHKA / climate control panel was stuck on high fan. None of the buttons work. Cannot change temp, vent settings, a/c on/off, etc.
    - Shut off car, restart the car and problem persists.
    - Disconnect battery, reconnect, and all's well. The climate control panel works normally, again. All's well.

    ... a few days later:
    - Get door chime when door is open, as if key is left in the ignition (but key is not in the ignition). This is strange.
    - Then, notice the keyless entry doesn't work. Don't have time to mess with it, so park it for now and lock using key.

    - Then, a few days later I go and drive it:
    - Notice the door chime key-in-ignition thing still, but key is not in ignition.
    - Keyless entry works again, to unlock and lock .... but the siren is set off within 30 sec of locking / arming.
    - Try arming the alarm and disabling motion sensor (read online a second press of lock button on key does this. Urban legend? who knows). No change. Siren still goes off. Door chime still there.
    - Unplug the rearview mirror. No change. Both the door chime and the siren still goes off. Plug in the rearview mirror again.
    - I unplug the hood switch and try keyless lock / arm... no change. Siren still goes off within 30 seconds of locking / arming.
    - Remove one of the two Anti-theft system fuses. Siren doesn't go off.

    So, now:
    - I still have the door chime thing,
    - No alarm siren because one of the two fuses is unplugged.
    - keyless entry works intermittently, but works the last 5 times I've tried.
    - battery voltage: 12.53.

    Final Stage Resistor?

  2. #2
    Join Date
    Jan 1970
    Location
    Southern California
    Posts
    17,859
    FSR is infamous for a parasitic battery drain.

    Sent from my SM-G998U using Tapatalk
    Randeaux/Rando/John/jr - '06 Cic ZHP; Southern California
    "ZHP or not, I still like you"


    ZHP Performance Package, Cold Weather Package, Leather, Jet Black/Black/BlackCube, NAV, Anthracite Black "my individual" interior trim
    ESS Stage 1 Twin Screw Supercharger, Sprint Booster, BMW Perf Intake, Magnaflow Exhaust, Dinan TB & STEP S/W, UCC Sway Bars, Apex EC-7 18x8.5 ET38
    Suspension: AST 44100 dampers, Bimmerworld front adjustable end links, Swift springs (8K front, 10K rear), Vorshlag camber plates
    Dynavin D99+, Hardwire V1 (w/V1 Connection), BSW Stage 1 Speakers, Kicker Amp/Subwoofer
    BMW Performance Strut Brace, Orion V2 Angel Eyes, No-holes License Plate, SMG Paddle Shift Mod, Besian VANOS, Gold DISA, Fan Delete, M3 Side Mirrors
    Note: Actual car no longer resembles signature picture

  3. #3
    Join Date
    Nov 2017
    Location
    Irvine, CA
    Posts
    636
    I think I'll bite the bullet and just try the FSR.

  4. #4
    Join Date
    Jun 2012
    Location
    Socal
    Posts
    1,526
    Hmm, it kind of sounds like gm5 going bad to me. Since it's affecting alarm and keyless entry. Usually FSR going bad just kills the battery.

  5. #5
    Join Date
    Nov 2017
    Location
    Irvine, CA
    Posts
    636
    Quote Originally Posted by sillieidiot View Post
    Hmm, it kind of sounds like gm5 going bad to me. Since it's affecting alarm and keyless entry. Usually FSR going bad just kills the battery.
    GM5! yes, I totally forgot about this module. I wasn't sure it was the FSR because it involved the alarm, and keyless entry. All the FSR failures are inability to adjust fan speed and dead battery. I'll look into this GM5 thing.

    Has anyone tried this guy, apparently in Torrance area of LA: https://www.bmwgm5.com/default.htm

  6. #6
    Join Date
    Jun 2012
    Location
    Socal
    Posts
    1,526
    Quote Originally Posted by Will View Post
    GM5! yes, I totally forgot about this module. I wasn't sure it was the FSR because it involved the alarm, and keyless entry. All the FSR failures are inability to adjust fan speed and dead battery. I'll look into this GM5 thing.

    Has anyone tried this guy, apparently in Torrance area of LA: https://www.bmwgm5.com/default.htm
    Yeah, he's well known on e46fanatics for fixing these. Should be your go to.

  7. #7
    Join Date
    Jan 1970
    Location
    Southern California
    Posts
    17,859
    Quote Originally Posted by sillieidiot View Post
    Hmm, it kind of sounds like gm5 going bad to me. Since it's affecting alarm and keyless entry. Usually FSR going bad just kills the battery.
    Good call!

    Sent from my SM-G998U using Tapatalk
    Randeaux/Rando/John/jr - '06 Cic ZHP; Southern California
    "ZHP or not, I still like you"


    ZHP Performance Package, Cold Weather Package, Leather, Jet Black/Black/BlackCube, NAV, Anthracite Black "my individual" interior trim
    ESS Stage 1 Twin Screw Supercharger, Sprint Booster, BMW Perf Intake, Magnaflow Exhaust, Dinan TB & STEP S/W, UCC Sway Bars, Apex EC-7 18x8.5 ET38
    Suspension: AST 44100 dampers, Bimmerworld front adjustable end links, Swift springs (8K front, 10K rear), Vorshlag camber plates
    Dynavin D99+, Hardwire V1 (w/V1 Connection), BSW Stage 1 Speakers, Kicker Amp/Subwoofer
    BMW Performance Strut Brace, Orion V2 Angel Eyes, No-holes License Plate, SMG Paddle Shift Mod, Besian VANOS, Gold DISA, Fan Delete, M3 Side Mirrors
    Note: Actual car no longer resembles signature picture

  8. #8
    Join Date
    Nov 2017
    Location
    Irvine, CA
    Posts
    636
    Just an update:

    - I still have the door chime thing, [resolved]
    - keyless entry works intermittently, but works the last 5 times I've tried [resolved]

    But here's what's weird, I didn't do anything.

    Now:
    The alarm will sound within 10 seconds of using remote to lock. I unplugged hood switch, still goes off. I changed hood switch, still goes off. So now i lock the car with the key to prevent the siren from going off. I'll mess with it later.

    This car has ghosts.

  9. #9
    Join Date
    Jun 2012
    Location
    Socal
    Posts
    1,526
    hood switch might not be making contact with the hood to press it all the way down? What happens when you lock the car while holding down the hood switch?

  10. #10
    Join Date
    Nov 2017
    Location
    Irvine, CA
    Posts
    636
    Quote Originally Posted by sillieidiot View Post
    hood switch might not be making contact with the hood to press it all the way down? What happens when you lock the car while holding down the hood switch?
    No change. The siren still goes off after about ~5 seconds.

    I've tried disconnecting the switch. No change, still goes off after ~5 seconds.

    I've set the alarm and held down the hood switch with my finger, then released the switch (simulating opening of the hood), and alarms goes off as it should.

    Another thing I've noticed is that the beep to signal locking and unlocking is very faint. The siren is normal volume.

    ... ghosts.

Page 1 of 2 12 LastLast

Similar Threads

  1. Electrical Gremlins
    By ryankokesh in forum Mechanical | Troubleshooting
    Replies: 16
    Last Post: 10-15-2013, 12:02 AM
  2. Things oil and electrical
    By Asiah119 in forum Mechanical | Troubleshooting
    Replies: 26
    Last Post: 07-16-2012, 10:37 AM
  3. Electrical problem???? need help
    By Johnny330zhp in forum Mechanical | Troubleshooting
    Replies: 14
    Last Post: 01-18-2012, 08:25 AM
  4. Electrical gremlins
    By adam_shifflett in forum Mechanical | Troubleshooting
    Replies: 11
    Last Post: 12-19-2011, 04:08 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •