Materials to Maintain Your ZHP IIIII Hand Protection IIIII Tools to Maintain Your ZHP
Results 1 to 4 of 4
  1. #1

    beep and a sudden temp fluctuation in the gauge display

    I was driving yesterday morning form a cold start, heard a beep followed by sudden temp fluctuation in the display gauge. I also noticed the AC stopped working it was blowing normal air.
    But today everything is looking ok, temp is normal and AC works, what could have caused it ?
    Attached Images Attached Images  

  2. #2
    Join Date
    Mar 2011
    Location
    Independence KY
    Posts
    2,713
    maybe your car is freaking out because its fuggin' negative 10deg outside lol, thats damn cold
    2005 BMW 330i ZHP - BMWP brakes/intake/strut bar/shifter, Coby wraps interior, BBS CHs, Eagle Eye LED tails, LED fog lights, GC coilovers, Sprint Booster/sport button mod, 4.5 LCM w/ programming, Xtrons 9inch HU, BSW stg1, dynamat, M3 sedan dead pedal, oCarbon CF interior trim, CF seat backs, 2x2 CF MTECH2 diffuser, CF cabin filter cover



  3. #3
    Join Date
    Jul 2016
    Location
    Boston, MA
    Posts
    125
    Maybe you have a bad ambient temp sensor? It's mounted under the car, near the front bumper..maybe on driver's side?

  4. #4
    Quote Originally Posted by Pilot05 View Post
    Maybe you have a bad ambient temp sensor? It's mounted under the car, near the front bumper..maybe on driver's side?

    I concur, looks like your external temperature sensor is bad. I had the same issue on my ZHP and it went away when I replaced this sensor. This sensor is located on the driver's side pork chop panel.
    Last edited by cakM3; 10-05-2022 at 08:16 AM.

Similar Threads

  1. Cheap and easy oil temp display on stock cluster
    By Galapolis in forum General -- ZHP Related
    Replies: 25
    Last Post: 05-10-2020, 02:50 PM
  2. Stand alone mech water temp gauge
    By OC570 in forum Performance
    Replies: 6
    Last Post: 08-22-2019, 05:02 PM
  3. PA SOFT: How to reprogram our temp gauge
    By NorCalZman in forum BMW Coding
    Replies: 100
    Last Post: 05-21-2017, 09:14 AM
  4. Engine hot but temp gauge is perfect
    By GOLDNSPOTS in forum Mechanical | Troubleshooting
    Replies: 13
    Last Post: 05-29-2014, 08:37 AM
  5. Temp Gauge Not Working
    By webster in forum Mechanical | Troubleshooting
    Replies: 13
    Last Post: 11-13-2012, 08:52 AM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •