Results 1 to 10 of 10

Thread: Got left with my sisters 99 325iT

  1. #1
    Join Date
    Aug 2011
    Location
    Richmond, VA
    Posts
    63

    Got left with my sisters 99 325iT

    My sister insisted on getting a BMW for her next car with the hopes I would fix it...well, she was right. The car is a blast to drive, but every time she brings it back home, something is wrong on it.

    I was taking it for a test drive yesterday and noticed the steering was all whacky, the car wanted to pull and the steering wheel off center. I decided I'd take it in for a quick alignment as a starting point.

    The initial readings on the car where all screwy with the toe settings, but came back with all sorts of other front suspension related issues:

    1. Ball joints - what I am assuming would be the tie rods and possible the control arms? I'm not sure what else is really under there in the front suspension that would have ball joints. Any suggestions?

    2. The Right front control arm is apparently bent. Not sure if my sister ran something over at some point, but we recently swapped out control arm bushings, and did not notice anything out of the ordinary.

    3. The rack and pinion bushings are worn...I'm not really sure what this means as I thought the rack was hard mounted to the car? I'm not familiar with this term or area as I haven't experienced any issues on any of the other cars.

    While driving, I also noticed the car wouldn't want to idle well at a stop light and was hesitant to start. She has an automatic, so I'm not sure if it is normal. Other than that, the car seemed to run recent. We recently replaced a fuel pump that smoothed the car out well, but I'm going to check DISA, ICV, and intake boots this afternoon.

    Also, the ASC-T and Brake light are both on. The Brake light is in yellow, which I'm guessing is ABS related? I'm not sure how to check where the issue might be without hooking the car up to a computer.

    I think that is all that is plaguing the car at the moment, so its looking more and more like a front suspension overhaul and a few other issues to address to get the car running right again.

    Any suggestions would be great, thanks guys!

  2. #2
    Sorry I don't have more to chime in on, but the brake light being on is probably just a pad wear sensor. Check the pads and discs and see if they're due for replacement.

    Zebra Horse Power - PSA: The Hypermiling Thread
    Kevin Savino-Riker
    Cogito Automation, LLC.
    I'm new at BMWs.

  3. #3
    Join Date
    Aug 2011
    Location
    Richmond, VA
    Posts
    63
    Thanks Kevin, I'll have to check those and see, I might have a couple extra sensors I can throw on there.

  4. #4
    If it is the yellow "BRAKE" light, then it is not the pads. The pad sensor light looks more like (O). I do not know about the tie rods, but the control arems do have ball joints, and I do not think they were available separately.

    Not sure about the rack and pinion "bushing" either. As for the rough idle and start, I think you're on the right track for basic troubleshooting, but first off, is the car throwing any check engine codes?

  5. #5
    I would jack the front of the car up to where the tires aren't touching the ground. After you do this wobble a tire up and down and then back and forth while someone else looks at the tie rods and control arms. If the tire moves up and down and the control arms aren't moving then your bushings and ball joints are bad in you Control arms. If your tire moves forward and backward, like it would if you were turning, and the tie rod doesn't move with it then you need new tie rod ends.

    Your steering rack is bolted to your vehicle BUT those bolts pass through some pretty serious bushings, these are the bushings that probably need replacings. You can tell if they are worn out if you can apply pressure to the wheels, like if you can put your car on a ramp or something, and steer the car back and forth. You'll see your steering rack move a little if this is the case.

    Checking your steering rack is probably gonna be rough, it's a little easier when you can get under the vehicle when it's on the ground.

  6. #6
    Join Date
    Mar 2011
    Location
    Quakertown, PA
    Posts
    410
    I would replace the fuel filter as soon as you can. Often overlooked and there is a chance it has the original one still in it. It may not fully fix the idle issue, but your sis will get better mileage and a smoother and quicker response when she steps on the gas.

    2002 330XI Saloon
    2005 ZHP
    2013 XC90 R-Design

  7. #7
    Join Date
    Aug 2011
    Location
    Richmond, VA
    Posts
    63
    Thanks for the suggestions, it will definitely be going up in the air tomorrow for further inspection before buying her parts. I did replace the fuel pump recently and made the car drive much better.

    I'll have to get a friend to help me check for bushing wear. It sounds like the steering rack bushings are out of my league for the time being, but fixing the others will likely make the car much better anyway.

    Thanks again!

  8. #8
    Join Date
    Mar 2011
    Location
    Quakertown, PA
    Posts
    410
    I did replace the fuel pump recently and made the car drive much better.
    Since you did the pump you should do the filter.

    2002 330XI Saloon
    2005 ZHP
    2013 XC90 R-Design

  9. #9
    Join Date
    Aug 2011
    Location
    Richmond, VA
    Posts
    63
    Filter was also changed...I should be a bit more descriptive with some of the previous maintenance haha. I'm going to have my shop check it out and see whats up with it this morning.

    Thanks!

  10. #10
    Join Date
    Aug 2011
    Location
    Richmond, VA
    Posts
    63
    I've been making some good progress on her car...ended up getting new Meyle control arms with powerflex bushings from Bimmerworld. Put them on the car this weekend and got the car back from alignment (which was wayyyyyy off) and the car is much better now.

    Still left to change the oil, window regulator, and replace the low beam bulbs. After that, it should be back into the engine to check for leaks and cracked boots, etc..never ends haha!

Similar Threads

  1. I shot her before I left her...
    By Rovert in forum ZHP Gallery and Video Section
    Replies: 16
    Last Post: 06-07-2012, 09:32 AM
  2. hello my ZHP brothers and sisters. Im finally home :)
    By Johnny330zhp in forum New Members (or older members who have not introduced themselves)
    Replies: 24
    Last Post: 01-19-2012, 09:55 PM
  3. For Sale (SOLD): 2002 BMW 325iT AW, blk lthr, 5 spd, 55K miles, $13.5K
    By BCS_ZHP in forum Other Automotive Classifieds (No ZHPs)
    Replies: 26
    Last Post: 10-15-2011, 11:23 AM
  4. Water spots left behind
    By jjcools in forum Detailing
    Replies: 2
    Last Post: 12-30-2010, 07:27 PM
  5. BMW pulling left/right at slow speeds
    By JHiggy in forum Mechanical | Troubleshooting
    Replies: 8
    Last Post: 11-08-2010, 04:17 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •