Results 1 to 4 of 4

Thread: COOLANT LEAK BUT WHERE?

  1. #1

    COOLANT LEAK BUT WHERE?

    Been a long time since I posted a thread. I been losing coolant for the past month with no evidence leaving behind (burning). Yesterday finally started to leak pretty good. I checked all the hoses from the radiator/expansion tank.

    Video below shows it leaking down the driver side of the engine. IT'S NOT the hose that goes to the block. Complete dry around that hose.

    Has anyone had issues with the heater core lines? Maybe Freeze plug?


    https://youtu.be/lxl5amQ8qEM

  2. #2
    Join Date
    Apr 2016
    Location
    Raleigh NC
    Posts
    127
    I see it has been over a month since you posted this thread... Did you find the source of the leak. If it were me I would use a coolant tester and put a small amount of pressure on via the expansion tank while finding the source of the leak.
    1980 320i - Kashmir Metallic - Sold in 1993
    1985 535i - Cosmosblau Metallic - Sold in 1995
    1985 535i - 1985-06 - Delphin Metallic - Sold in 2016
    1983 320i - 1982-09 - Kashmir Metallic - Currently own!
    2004 ZHP - 2003-08 - Titanium Metallic - Currently own!

  3. #3
    The spots I've had issues with on my car were 1.) the weep hole on the bottom of the water pump. This is in front of the engine block though, and when it drips, it lands on the belts and gets thrown around the engine bay. 2.) bottom of the expansion tank was starting to leak at the pull pin that connects the expansion tank to the mount. This would let the coolant drip down one of the hoses some, leading me to believe it was the hose, and not the expansion tank.

    Hopefully you figured it out by now, but as a suggestion, if your expansion tank is older, replace it anyways!

  4. #4
    Join Date
    Oct 2016
    Location
    Chicago, IL
    Posts
    12
    I would check the lower radiator hose. there is a temp sensor on this hose, and the o ring is known to break, and it leaks. i'd replace the hose and sensor, since you can get both parts for cheap, and its an easy DIY

    also, sounds like your VANOS needs a rebuild :D

Similar Threads

  1. Weird coolant leak...
    By ecrabb in forum Mechanical | Troubleshooting
    Replies: 16
    Last Post: 06-25-2016, 11:02 PM
  2. Coolant Leak
    By san in forum Mechanical | Troubleshooting
    Replies: 42
    Last Post: 11-24-2014, 06:46 PM
  3. Coolant leak
    By Dave1027 in forum Mechanical | Troubleshooting
    Replies: 37
    Last Post: 04-27-2013, 11:24 PM
  4. Coolant leak - temp sensor o-ring
    By Pip in forum Mechanical | Troubleshooting
    Replies: 21
    Last Post: 12-12-2012, 07:10 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •